Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 мая 2024, 06:53

Нужно помощь

Автор shamsbjj, 02 мая 2024, 09:42

0 Пользователей и 1 гость просматривают эту тему.

shamsbjj

Добрый день ! подскажите пожалуйста у меня есть такая процедура ДобавитьУдалитьИзГруппыДоступа

я хочу тут удалить доступы пользователя из ТЧ если не удаляться иначе хочу добавить 

antoneus

Удалять строки из ТЧ в цикле по ней же - так себе затея. Попробуйте так

Строки = ГруппаДоступаОбъект.Пользователи.НайтиСтроки(Новый Структура("Пользователь", Пользователь));
Если Удалить Тогда
    Для каждого СтрТЧ из Строки Цикл
        ГруппаДоступаОбъект.Пользователи.Удалить(СтрТЧ)
    КонецЦикла;
ИначеЕсли Строки.Количество() = 0 Тогда
    ГруппаДоступаОбъект.Пользователи.Добавить().Пользователь = Пользователь
КонецЕсли;

ГруппаДоступаОбъект.Записать();

shamsbjj

antoneus, ГруппаДоступаОбъект = ГруппаДоступа.ПолучитьОбъект(); 
   
   СтрокаПользователя = ГруппаДоступаОбъект.Пользователи.Найти(Пользователь, "Пользователь"); 
   
   Если Удалить Тогда
      
      Если СтрокаПользователя <> Неопределено Тогда
         ГруппаДоступаОбъект.Пользователи.Удалить(СтрокаПользователя);
      КонецЕсли;
      
   Иначе
      
      Если СтрокаПользователя = Неопределено Тогда
         СтрокаПользователя = ГруппаДоступаОбъект.Пользователи.Добавить();
         СтрокаПользователя.Пользователь = Пользователь;   
      КонецЕсли;
   
   КонецЕсли;
   
   Если ГруппаДоступаОбъект.Модифицированность() Тогда
      ГруппаДоступаОбъект.Записать();
   КонецЕсли;

shamsbjj

antoneus, вот так но у меня удаления происходить но не добавляется

shamsbjj

теперь дает такой ошибка и поля Гд не обнаружено пишет

Максим75

shamsbjj, посмотрите в выборке, скорее всего нет такого реквизита.
ну дайте хотя бы полный текст, а то гадать где и чего не хочется.

shamsbjj

Максим75, спасибо большое  нашел ошибку у меня во втором запросе в выборке НЕТ  поля ГД. Есть только поле ГруппаДоступа переименовал ГруппаДоступа в ГД и сработало 

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск