Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 фев 2024, 09:40

Нужно помощь

Автор shamsbjj, 02 ноя 2023, 08:50

0 Пользователей и 1 гость просматривают эту тему.

shamsbjj

   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ДанныеИзИБС.ФизическоеЛицо КАК ФизическоеЛицо,
      |   ДанныеИзИБС.Дата КАК Дата,
      |   СУММА(ДанныеИзИБС.Количество) КАК Количество,
      |   СУММА(ДанныеИзИБС.Сумма) КАК Сумма,
      |   ДанныеИзИБС.Номенклатура КАК Номенклатура,
      |   ДанныеИзИБС.ИДИБС КАК ИДИБС,
      |   Переченьсписываемыхаксессуаров.Номенклатура КАК НоменклатураБиллинга,
      |   Переченьсписываемыхаксессуаров.IDбиллинга КАК IDбиллинга
      |ИЗ
      |   РегистрСведений.ДанныеИзИБС КАК ДанныеИзИБС
      |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.Переченьсписываемыхаксессуаров КАК Переченьсписываемыхаксессуаров
      |      ПО ито_ДанныеИзИБС.ИДИБС = Переченьсписываемыхаксессуаров.ID
      |
      |СГРУППИРОВАТЬ ПО
      |   ДанныеИзИБС.Дата,
      |   ДанныеИзИБС.Номенклатура,
      |   Переченьсписываемыхаксессуаров.Номенклатура,
      |   Переченьсписываемыхаксессуаров.ID,
      |   ДанныеИзИБС.ИДИБС,
      |   ДанныеИзИБС.ФизическоеЛицо";
   
   РезультатЗапроса = Запрос.Выполнить();
   
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   
      
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      
   КонецЦикла;   
   

Почему при нажатия кнопка грузиться и результат не показывает

Максим75

shamsbjj, а куда, простите, результат должен показаться, судя по куда - никуда.

shamsbjj

А как сделать ? что можно писать в цикле?

LexaK

Цитата: shamsbjj от 02 ноя 2023, 09:31А как сделать ? что можно писать в цикле?
можно писать Сообщить.
вот пример
     
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      Сообщить("" + ВыборкаДетальныеЗаписи.ФизическоеЛицо + ", " + ВыборкаДетальныеЗаписи.Дата); //и так далее
   КонецЦикла;   
если помогло нажмите: Спасибо!

shamsbjj

LexaK, Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ито_ДанныеИзИБС.ФизическоеЛицо КАК ФизическоеЛицо,
      |   ито_ДанныеИзИБС.Дата КАК Дата,
      |   СУММА(ито_ДанныеИзИБС.Количество) КАК Количество,
      |   СУММА(ито_ДанныеИзИБС.Сумма) КАК Сумма,
      |   ито_ДанныеИзИБС.Номенклатура КАК Номенклатура,
      |   ито_ДанныеИзИБС.ИДИБС КАК ИДИБС,
      |   МФ_Переченьсписываемыхаксессуаров.Номенклатура КАК НоменклатураБиллинга,
      |   МФ_Переченьсписываемыхаксессуаров.IDбиллинга КАК IDбиллинга
      |ИЗ
      |   РегистрСведений.ито_ДанныеИзИБС КАК ито_ДанныеИзИБС
      |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.МФ_Переченьсписываемыхаксессуаров КАК МФ_Переченьсписываемыхаксессуаров
      |      ПО ито_ДанныеИзИБС.ИДИБС = МФ_Переченьсписываемыхаксессуаров.IDбиллинга
      |
      |СГРУППИРОВАТЬ ПО
      |   ито_ДанныеИзИБС.Дата,
      |   ито_ДанныеИзИБС.Номенклатура,
      |   МФ_Переченьсписываемыхаксессуаров.Номенклатура,
      |   МФ_Переченьсписываемыхаксессуаров.IDбиллинга,
      |   ито_ДанныеИзИБС.ИДИБС,
      |   ито_ДанныеИзИБС.ФизическоеЛицо";
   
   РезультатЗапроса = Запрос.Выполнить();
   
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   
      
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      
        Сообщить("" + ВыборкаДетальныеЗаписи.ФизическоеЛицо + ", " + ВыборкаДетальныеЗаписи.Дата);
      
   КонецЦикла;   




почему при нажатия кнопка ничего не происходить ?

shamsbjj


shamsbjj

LexaK, Смотрите я создал обработку там создал кнопку внутри это кнопка сделал запрос и хочу при нажатья на кнопку вывести результат он грузиться ничего не покажет

LexaK

Цитата: shamsbjj от 02 ноя 2023, 09:59почему при нажатия кнопка ничего не происходить ?
может данные вообще нет в регистрах?

есть такая обработка Консоль запросов
запустите ее, в ней как раз можно проверять разрабатываемые запросы, выполнять их и сразу видеть результат!
если помогло нажмите: Спасибо!

shamsbjj

LexaK, там тоже такой же результат

shamsbjj

LexaK, 1 запись есть там

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск