Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 апр 2024, 01:01

Имя сохраняемого файла

Автор S.Boev, 26 окт 2018, 12:36

0 Пользователей и 1 гость просматривают эту тему.

S.Boev

Всем привет!
Подскажите, пожалуйста, никак не могу найти решение задачи: где можно отредактировать имя сохраняемого файла?
Сейчас сохраняю файл с именем "Счет на оплату (факсимиле) № ФР-104 от 26.10.2018", а хочу добавить туда название организации, на которую выставлен счёт, чтобы в папке в массиве сохранённых счетов сразу был виден клиент.

1С:Предприятие 8.3 (8.3.12.1469)
УНФ 1.6 (1.6.15.55)



oleg-x

Найти место где формируется название файла и добавить немного кода
ИмяФайла+ Ссылка.Организация
Код примерный, зависит от того как написана процедура.
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

S.Boev

oleg-x, спасибо!
Долго искал, но нашёл, всё сработало. Может кому пригодится.
Заходим в "Общие формы –> Печать документов".
Ищем функцию:
&НаСервере
Функция ИмяФайлаПечатнойФормыПоУмолчанию(ОбъектПечати, НазваниеПечатнойФормы)

Если ОбщегоНазначения.ЭтоДокумент(Метаданные.НайтиПоТипу(ТипЗнч(ОбъектПечати))) Тогда
ПараметрыДляВставки = ОбщегоНазначения.ЗначенияРеквизитовОбъекта(ОбъектПечати, "Дата,Номер,Контрагент");
Если ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.ПрефиксацияОбъектов") Тогда
МодульПрефиксацияОбъектовКлиентСервер = ОбщегоНазначения.ОбщийМодуль("ПрефиксацияОбъектовКлиентСервер");
ПараметрыДляВставки.Номер = МодульПрефиксацияОбъектовКлиентСервер.НомерНаПечать(ПараметрыДляВставки.Номер);
КонецЕсли;
ПараметрыДляВставки.Дата = Формат(ПараметрыДляВставки.Дата, "ДЛФ=D");
ПараметрыДляВставки.Вставить("НазваниеПечатнойФормы", НазваниеПечатнойФормы);
Шаблон = НСтр("ru = '[НазваниеПечатнойФормы] [Контрагент] № [Номер] от [Дата]'");
Иначе
ПараметрыДляВставки = Новый Структура;
ПараметрыДляВставки.Вставить("НазваниеПечатнойФормы",НазваниеПечатнойФормы);
ПараметрыДляВставки.Вставить("ПредставлениеОбъекта", ОбщегоНазначения.ПредметСтрокой(ОбъектПечати));
ПараметрыДляВставки.Вставить("ТекущаяДата",Формат(ТекущаяДатаСеанса(), "ДЛФ=D"));
Шаблон = НСтр("ru = '[НазваниеПечатнойФормы] - [ПредставлениеОбъекта] - [ТекущаяДата]'");
КонецЕсли;

Возврат СтроковыеФункцииКлиентСервер.ВставитьПараметрыВСтроку(Шаблон, ПараметрыДляВставки);

КонецФункции


Я добавил слово "Контрагент" в две строки: в "ПараметрыДляВставки" и в "Шаблон".

Похожие темы (5)

Рейтинг@Mail.ru

Поиск