Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 апр 2024, 11:36

Автоматическое заполнение табличной части

Автор Nikita126, 05 июл 2018, 18:01

0 Пользователей и 1 гость просматривают эту тему.

Nikita126

ПОЖАЛУЙСТА ПОМОГИТЕ РЕШИТЬ ПРОБЛЕМУ! Конфигурация самописная 8.2
Есть документ "Приём на работу" и табличная часть "Предоставляемые документы" (НаименованиеДокументы ,СтраницаДокумента ,ФорматДокумента) ,нужно ,что бы ТЧ "Предоставляемые документы" заполнялась сразу при создании.

wise

(0) В форме ПриОткрытии()
Если ЭтоНовый() Тогда
   НоваяСтрока = ПредоставляемыеДокументы.Добавить();
   НоваяСтрока.НаименованиеДокумента = "Паспорт";
   ...........
   ...........
КонецЕсли;
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Nikita126

Цитата: wise от 05 июл 2018, 18:41
(0) В форме ПриОткрытии()
Если ЭтоНовый() Тогда
   НоваяСтрока = ПредоставляемыеДокументы.Добавить();
   НоваяСтрока.НаименованиеДокумента = "Паспорт";
   ...........
   ...........
КонецЕсли;


Ошибку выдаёт (((

{Документ.ВРЕМЕННАЯ_РЕГИСТРАЦИЯ.Форма.ФормаДокумента.Форма(15,18)}: Переменная не определена (ПредоставляемыеДокументы)
   НоваяСтрока = <<?>>ПредоставляемыеДокументы.Добавить();
{Документ.ВРЕМЕННАЯ_РЕГИСТРАЦИЯ.Форма.ФормаДокумента.Форма(14,7)}: Процедура или функция с указанным именем не определена (ЭтоНовый)
   Если <<?>>ЭтоНовый() Тогда

alex0402

Цитата: Nikita126 от 07 июл 2018, 20:59{Документ.ВРЕМЕННАЯ_РЕГИСТРАЦИЯ.Форма.ФормаДокумента.Форма(15,18)}: Переменная не определена (ПредоставляемыеДокументы)

можно попробовать
НоваяСтрока = Объект.ПредоставляемыеДокументы.Добавить();
но лучше это делать в ОбработкаЗаполнения в модуле объекта.
Спасибо за Сказать спасибо

Nikita126

Цитата: alex0402 от 08 июл 2018, 13:00
Цитата: Nikita126 от 07 июл 2018, 20:59{Документ.ВРЕМЕННАЯ_РЕГИСТРАЦИЯ.Форма.ФормаДокумента.Форма(15,18)}: Переменная не определена (ПредоставляемыеДокументы)

можно попробовать
НоваяСтрока = Объект.ПредоставляемыеДокументы.Добавить();
но лучше это делать в ОбработкаЗаполнения в модуле объекта.

Если ПриОткрытии то ошибка:

{Документ.Документ1.Форма.ФормаДокумента.Форма(5,9)}: Процедура или функция с указанным именем не определена (ЭтоНовый)
   Если <<?>>ЭтоНовый() Тогда (Проверка: Тонкий клиент)
{Документ.Документ1.Форма.ФормаДокумента.Форма(5,9)}: Процедура или функция с указанным именем не определена (ЭтоНовый)
   Если <<?>>ЭтоНовый() Тогда (Проверка: Веб-клиент)

Если ОбработкаЗаполнения то вот :

{Документ.Документ1.МодульОбъекта(4,18)}: Переменная не определена (Объект)
   НоваяСтрока = <<?>>Объект.ПредоставляемыеДокументы.Добавить(); (Проверка: Сервер)
{Документ.Документ1.МодульОбъекта(4,18)}: Переменная не определена (Объект)
   НоваяСтрока = <<?>>Объект.ПредоставляемыеДокументы.Добавить(); (Проверка: Внешнее соединение)

Везде ошибка(

alex0402

Цитата: Nikita126 от 07 июл 2018, 20:59НоваяСтрока = ПредоставляемыеДокументы.Добавить();
   НоваяСтрока.НаименованиеДокумента = "Паспорт";

Процедура ОбработкаЗаполнения(ДанныеЗаполнения)
    НоваяСтрока = ПредоставляемыеДокументы.Добавить();
    НоваяСтрока.НаименованиеДокумента = "Паспорт";
КонецПроцедуры
Спасибо за Сказать спасибо

Похожие темы (5)

Рейтинг@Mail.ru

Поиск