Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 мая 2024, 06:48

Добавить наименование контрагента в комментарий

Автор vienya, 24 апр 2024, 08:47

0 Пользователей и 1 гость просматривают эту тему.

vienya

Выручайте!
БП Корп 8,3. Как обратиться к полю Наименование?   
Процедура ВКомментарий () 
    Если Найти(Контрагент.Наименование, []) = 1 Тогда
                 Контрагент.Комментарий = []; //так подставить, будет правильно?
        КонецЕсли;
КонецПроцедуры
Что только не пробовал сюда []* подставлять, пишет, что переменная [] не определена. :dfbsdfbsdf:
* - Наименование, НаименованиеКонтрагента, КонтрагентНаименование, ""... :dfbbdrfb:

LexaK

vienya, не очень понятно что и по какому условию вам надо что-то изменить в Контрагенте
есть обработка внешняя или встроенная ГрупповоеИзменениеРеквизитов,
Запустите ее, укажите справочник Контрагенты, задайте условие отбора, выберите реквизит который надо изменить
и запустите обработку.

Внимание! Сначала потренируйтесь на тестовой копии базы.
если помогло нажмите: Спасибо!

vienya

LexaK, спасибо! Вопрос решён, по вашему совету.
Внесение лицевого счета в комментарий осуществлено через штатную обработку ГруповоеИзменениеРеквизитов (Администрирование > Обслуживание > Корректировка данных)
- Ввести новые значения – открыжены все, связанные с Контрагентами поля.
- Выполнить произвольный алгоритм:
ПервыеДесятьСимволовНаименования = Лев(Объект.Наименование, 10);
Если СтрДлина(ПервыеДесятьСимволовНаименования) = 10
    И СтрРазделить(ПервыеДесятьСимволовНаименования,"0123456789",Ложь).Количество() = 0 Тогда
               Объект.Комментарий = ПервыеДесятьСимволовНаименования;
               Объект.Наименование = СокрЛ(Сред(Объект.Наименование, 11)); //удалить лицевой счет из наименования
               Объект.НаименованиеПолное = СокрЛ(Сред(Объект.НаименованиеПолное, 11)); //удалить лицевой счет из полного наименования
КонецЕсли; 
- Выбор элементов для изменения: Отбор по Юридическое/физическое лицо = Физическое лицо,
Дата создания Больше/Меньше (сортирую по дате, т.к. большой объём, поэтому гружу по частям)
 

vienya

Но есть нюанс. В форму Контрагента внесён дополнительный выпадающий список. Если он не заполнен обработка не срабатывает. Должен быть заполнен значением выпадающего списка ВС. Пытаюсь заполнить его принудительно, но не знаю как обратиться:
Объект.ДК1_СтатусМСФО = [СписокЗначений.ВС, СписокВыбора.ВС, просто по значению "ВС" ]- ничего не срабатывает.

При этом для нового заполнения допреквизит ВС легко выставляется по умолчанию в палитре свойств. Вопрос, как его выставить принудительно для всех незаполненных?

vienya

vienya, Нашёл: Объект.ДК1_СтатусМСФО = Перечисления.ДК1_СтатусМСФО.ВС   :zebzdr:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск