Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 июн 2024, 01:32

Открытие формы по условию

Автор Алексей_1985_06, 13 апр 2024, 21:09

0 Пользователей и 2 гостей просматривают эту тему.

Алексей_1985_06

Всем доброго времени! Подскажите пожалуйста, необходимо при создании нового элемента справочника открывать форму документа, попробовал реализовать так:

1. Создал реквизит формы "ЭтоНовыйСотрудник" - тип Булево, указывает новый элемент создается или нет:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

Если Параметры.Ключ.Пустая() Тогда
   ЭтоНовыйСотрудник = Истина
КонецЕсли;

КонецПроцедуры

2. После записи (когда есть ссылка на элемент) хочу открыть форму документа, но в таком случае при нажатии на кнопку "Записать и закрыть" вопрос соответсвенно не виден пользователю, подскажите как можно реализовать?

&НаКлиенте
Процедура ПослеЗаписи(ПараметрыЗаписи)

Если ЭтоНовыйСотрудник = Истина И НЕ Параметры.Ключ.Пустая() Тогда // Если это новый записанный в БД сотрудник 
ОписаниеОповещения = Новый ОписаниеОповещения ("ПослеОтветаНаВопрос",ЭтотОбъект);
ПоказатьВопрос(ОписаниеОповещения, "Записать предыдущие должности сотрудника?",РежимДиалогаВопрос.ДаНетОтмена,,,"Ввод данных нового сотрудника");
ЭтоНовыйСотрудник = Ложь // скидываем флаг
КонецЕсли

КонецПроцедуры


&НаКлиенте   
Процедура ПослеОтветаНаВопрос (РезультатВопроса,ДополнительныеПараметры) Экспорт

Если  РезультатВопроса = КодВозвратаДиалога.Да Тогда 
ОткрытьФорму("Документ.ДокументНазначениеНаДолжностьВнеОрганизации.ФормаОбъекта")
КонецЕсли; 

КонецПроцедуры

axe44

Сама идея не правильная.
При "Записать и закрыть" идёт закрытие формы.
Нужно после записи открывать общую форму с диалогом, от куда будет задаваться вопрос пользователю.

После Записи Сотрудник не Новый и Ссылка не пустая.

То есть после записи есть ссылка, по которой с клиента можно поискать срез последних на сервере в регистре Кадровые данные срез последних записи.

Алексей_1985_06

axe44, Ага, спасибо исправил. Можете подсказать как теперь из формы элемента справочника передать значение ссылки на сотрудника (например: Иванов И.И.) в табличную часть "Сотрудники" а конкретно в поле "ФИО" этой табличной части открываемого документа?

bsn-chita

В параметры положить ссылку на сотрудника и при создании на сервере в форме открываемого документа взять и использовать где нужно.

LexaK

еще как вариант, в справочнике сделайте реквизит ПредыдцщиеДолжности (Ссылка на документ)
и выведите этот реквизит на форму элемента - Сотрудника
при создании нового сотрудника это поле будет пустое
после записи Сотрудника, при необходимости ввести предыдущие должности
оператор нажимает на это поле, при создании новгого сотрудника оно пустое создаете новый документ Должности и передаете в параметрах ссылку на сотрудника.

а если сотрудник уже был создан, то можно легко перейти в документ его предыдущих должностей.
или можно ввести нового сотрудника и отложить на потом создание ввода должностей,
а затем легко найт сотрудников без этого документа и доввести нужные данные
и тд.
если помогло нажмите: Спасибо!

Алексей_1985_06

LexaK, Большое спасибо за помощь!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск