Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 мая 2024, 06:42

Поле обьекта не обнаружено(Номер телефона). Где-то накосячил с написанием кода для внешней печатной

Автор VladislavShax, 08 апр 2024, 08:57

0 Пользователей и 1 гость просматривают эту тему.

VladislavShax

1С:Предприятие 8.3 (8.3.19.1522)
1С Колледж ПРОФ, редакция 2.1 (2.1.6.1)

Здравствуйте! По какой-то причине в мою печатную форму не выводится информация из документа. А именно: Номер телефона, страна, город, регион, Район и средний балл аттестата. Сами данные в документе имеются, но при попытке открыть документ уже в клиенткой части - пишет "Поле объекта не обнаружено". Скрины всего, что может в теории понадобиться прилагаю ниже:

fruitella

Ну наверно потому что у тебя в запросе выбирается дополнительно табличная часть "Контактная информация". Нужно в цикле детальных записей получить выборку табличной части и от туда реквизиты передавать в параметры. Можешь сделать это так к примеру:

//Внутри цикла
СписокКонтактнойИнформации = ВыборкаДетальныеЗаписи.КонтактнаяИнформация.Выгрузить();

Для Каждого Контакты Из СписокКонтактнойИнформации Цикл
    //Тут уже передаешь данные в параметры
    ОбластьИнформация.Параметры.НомерТелефона = Контакты.НомерТелефона;
    //И так далее
КонецЦикла;

VladislavShax

fruitella, Да, это помогло, но только с контактной информацией. Со средним баллом аттестата все та же ересь, хотя информация о среднем балле в базе имеется.картинка1.PNGкартинка2.png 

antoneus


VladislavShax

antoneus, Заметил, спасибо, был невнимателен. Печатная форма наконец вывелась, но с номером все еще проблемы, его так и нету :С
1231231231.png

antoneus

А вы прям вот так в цикле параметр и заполняете?

Для Каждого Контакты Из СписокКонтактнойИнформации Цикл
    //Тут уже передаешь данные в параметры
    ОбластьИнформация.Параметры.НомерТелефона = Контакты.НомерТелефона;
    //И так далее
КонецЦикла;

Просто если в контактной информации несколько строк и после номера телефона идет строка с другой инфой - номер телефона затрется.


antoneus

А зачем город, регион и прочее пихать в номер телефона? Во-первых, они там не нужны, во-вторых, говорю - если эти поля не заполнены, номер телефона тупо затрется, в-третьих, эти значения нужно класть в другие параметры - Город, Регион и проч.

ВыборкаКИ = ВыборкаДетальныеЗаписи.КонтакнаяИнформация.Выбрать();
Пока ВыборкаКИ.Следующий() Цикл
    Если ВыборкаКИ.НомерТелефона <> "" Тогда
        ОбластьИнформация.Параметры.НомерТелефона = ВыборкаКИ.НомерТелефона;       
    КонецЕсли;
    //аналогично заполняем другие параметры
КонецЦикла;

VladislavShax

antoneus, Хорошо, а как тогда правильно вносить эти данные? Просто всё это находится в одной табличной части "контактная информация". Создавать для них отдельный запрос?

antoneus

так

ВыборкаКИ = ВыборкаДетальныеЗаписи.КонтакнаяИнформация.Выбрать();
Пока ВыборкаКИ.Следующий() Цикл
    Если ВыборкаКИ.НомерТелефона <> "" Тогда
        ОбластьИнформация.Параметры.НомерТелефона = ВыборкаКИ.НомерТелефона;       
    КонецЕсли;
    Если ВыборкаКИ.Страна <> "" Тогда
        ОбластьИнформация.Параметры.Страна = ВыборкаКИ.Страна;       
    КонецЕсли;
    Если ВыборкаКИ.Регион <> "" Тогда
        ОбластьИнформация.Параметры.Регион = ВыборкаКИ.Регион;
    КонецЕсли;
    Если ВыборкаКИ.Город <> "" Тогда
        ОбластьИнформация.Параметры.Город = ВыборкаКИ.Город;       
    КонецЕсли;
    Если ВыборкаКИ.Район<> "" Тогда
        ОбластьИнформация.Параметры.Район = ВыборкаКИ.Район;       
    КонецЕсли;

КонецЦикла;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск