Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
15 июл 2024, 04:34

Обновление расширений в зависимости от конфигурации

Автор FantomASS, 21 мар 2024, 11:21

0 Пользователей и 1 гость просматривают эту тему.

FantomASS

Добрый день! У меня хранятся данные в виде таблички с названиями клиентов и какая у него конфигурация: бухгалтерия, зуп, унф. в табличке эти значения булево. и мне надо в зависимости от того, какая конфигурация, ставить определенное расширение. так вот, как можно сделать обработку каждого варианта
Функция ПутькРасширениям1С()

Возврат Константы.ПутьКРасширениям1С.Получить();
КонецФункции

Функция Расширения1С() Экспорт

КаталогРасширений = ПутькРасширениям1С();

Расширения1С = Новый Структура;
Расширения1С.Вставить("РасширениеБухгалтерия", КаталогРасширений + "\" + "Расширение.cfe");
Расширения1С.Вставить("РасширениеЗУП", КаталогРасширений + "\" + "Расширение1.cfe");
Расширения1С.Вставить("РасширениеУНФ", КаталогРасширений + "\" + "Расширение2.cfe");

Сообщить(Расширения1С);
Возврат Расширения1С;

КонецФункции
Процедура ВыгрузитьРасширение() Экспорт

Команда = """[ПолноеИмяПрограммы1С]"" DESIGNER /F ""[Расположение]"" /N ""[Логин]"" /P ""[Пароль]"" /LoadCfg ""[ПутьКФайлу]"" -Extension Расширение1 /UpdateDBCfg""";

Команда = СтрЗаменить(Команда, "[ПолноеИмяПрограммы1С]", ЭтотОбъект.Форма.ПолноеИмяПрограммы1С);
Команда = СтрЗаменить(Команда, "[Расположение]", ЭтотОбъект.Форма.Расположение);
Команда = СтрЗаменить(Команда, "[Логин]", ЭтотОбъект.Форма.Логин);
Команда = СтрЗаменить(Команда, "[Пароль]", ЭтотОбъект.Форма.Пароль);
Команда = СтрЗаменить(Команда, "[ПутьКФайлу]", Расширения1С.ПутьКФайлу);

КодВозврата = "";
ЗапуститьПриложение(Команда, , Истина, КодВозврата);
Сообщить(КодВозврата);

КонецПроцедуры

Функция НовыйСтруктураРасположенияРасширений()

РасположениеРасширений = Новый Структура;

РасположениеРасширений.Вставить("Клиент", Справочники.Клиенты.ПустаяСсылка());
РасположениеРасширений.Вставить("Accounting", Ложь);
РасположениеРасширений.Вставить("HRM", Ложь);
РасположениеРасширений.Вставить("SmallBusiness", Ложь);
РасположениеРасширений.Вставить("Расположение",Справочники.Расположение.ПустаяСсылка());

Возврат РасположениеРасширений;


КонецФункции


Для каждого Строка из ЭтотОбъект.РасположениеРасширений Цикл
Если Строка.Accounting Тогда
//Обработка Бухгалтерии
ИначеЕсли Строка.HRM Тогда
//Обработка ЗУП
ИначеЕсли Строка.SmallBusiness Тогда
//Обработка УНФ
КонецЕсли;
КонецЦикла;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск