Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 мая 2024, 03:29

Разные результаты в скд и консоли запросов

Автор Sasha1C, 05 мар 2024, 15:55

0 Пользователей и 1 гость просматривают эту тему.

Sasha1C

Подскажите пожалуйста почему консоль запросов и скд выдают разные результаты, форумы говорят об неточностях  в запросе. И еще один всплывающий вопрос, как преобразовать этот запрос. Сам результат выводится списком через конструктор компоновки данных, но он появляется пустым, а через консоль появляются данные. Прикрепляю скрины, где привожу пример вывода отчета, также результат скд и консоли. Где искать ошибку? :xfbnsdfb: 
ВЫБРАТЬ
КоличествоПоездокОбороты.ТранспортноеСредство КАК ТранспортноеСредство,
КоличествоПоездокОбороты.Водитель КАК Водитель,
СУММА(КоличествоПоездокОбороты.КилометражОборот) КАК КилометражОборот
ИЗ
РегистрНакопления.КоличествоПоездок.Обороты(&ДатаНачала, &ДатаОкончания, , Водитель = &Водитель) КАК КоличествоПоездокОбороты

СГРУППИРОВАТЬ ПО
КоличествоПоездокОбороты.Водитель,
КоличествоПоездокОбороты.ТранспортноеСредство

Sasha1C

На всякий приложу объявление параметров для скд в форме отчета


&НаСервере
Процедура ПриИзмененииНаСервереПараметров()

ЭтаФорма.Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Водитель", Отчет.Водитель);
ЭтаФорма.Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("ДатаНачала", Отчет.ДатаНачала);
ЭтаФорма.Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("ДатаОкончания", отчет.ДатаОкончания);

КонецПроцедуры

&НаКлиенте
Процедура ДатаНачалаПриИзменении(Элемент)
ПриИзмененииНаСервереПараметров();
КонецПроцедуры

&НаКлиенте
Процедура ДатаОкончанияПриИзменении(Элемент)
ПриИзмененииНаСервереПараметров();
КонецПроцедуры

&НаКлиенте
Процедура ВодительПриИзменении(Элемент)
ПриИзмененииНаСервереПараметров();
КонецПроцедуры


Максим75

Sasha1C, Вы же видите, что из трех параметров у Вас только один заполнен.

Sasha1C

Максим75, Спасибо, там не правильная процедура подтягивалась при изменении

Теги: скд Запрос 

Похожие темы (5)

Рейтинг@Mail.ru

Поиск