Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 мая 2024, 02:07

Необходимо изменить выделенные строки динамического списка в форме спровчника.

Автор Pain1889, 19 фев 2024, 19:14

0 Пользователей и 1 гость просматривают эту тему.

Pain1889

Необходимо, чтобы при выделении одной или нескольких строк устанавливалось значение в строку  Выдано

Как это сделать? не могу решить эту задачу....


&НаКлиенте
Процедура Выдать(Команда)
ВыделенныеСтроки = Элементы.Список.ВыделенныеСтроки;
МассивСтрок = Новый Массив();
Для Каждого Строка Из Элементы.Список.ВыделенныеСтроки Цикл
МассивСтрок.Добавить(Элементы.Список.ДанныеСтроки(Строка)["Выдано"]=ВыборВыдачи);
КонецЦикла;
СписокВыборНаСервере(МассивСтрок);     
КонецПроцедуры

&НаСервере
Процедура СписокВыборНаСервере(ВыделенныеСтроки)

   
//Как внести измнения?

   
   
КонецПроцедуры



LexaK

Pain1889, примерно так можно сделать
&НаСервере
Процедура Команда1НаСервере(Знач мСтроки)
Для каждого лкЭлемент Из мСтроки Цикл
лкОб = лкЭлемент.Получитьобъект();
//ваш код по изменению
лкОб.Записать();
КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
Команда1НаСервере(Элементы.Список.ВыделенныеСтроки);
КонецПроцедуры
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск