Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 мая 2024, 16:17

Получение Текущего пользователя

Автор Funt432286, 01 фев 2024, 14:36

0 Пользователей и 1 гость просматривают эту тему.

Funt432286

Всем доброго времени суток!

Пытаюсь определить текущего пользователя, но после обновления системы, что-то идет не так!
Управляемое приложение

ТекПользователь = ПользователиКлиентСервер.ТекущийПользователь();

Если Строка(ТекПользователь) = "ТСД1" или Строка(ТекПользователь) = "Администратор" Тогда
ОкноТСД = ПолучитьФорму("Обработка.ТСД_РабочийСтол.Форма.Форма");
ОкноТСД.Открыть();
КонецЕсли;


{МодульУправляемогоПриложения(88,20)}: Переменная не определена (ПользователиКлиентСервер)
ТекПользователь = <<?>>ПользователиКлиентСервер.ТекущийПользователь(); (Проверка: Мобильный клиент (автономная конфигурация). Клиент)
Мобильное приложение содержит синтаксические ошибки.


alexandr_ll



fruitella

Если Сервер, пробни так
ТекПользователь = Пользователи.АвторизованныйПользователь();


Funt432286

Funt432286,

Процедура ПриНачалеРаботыСистемы()

// СтандартныеПодсистемы
#Если МобильныйКлиент Тогда
Выполнить("СтандартныеПодсистемыКлиент.ПриНачалеРаботыСистемы()");
#Иначе
СтандартныеПодсистемыКлиент.ПриНачалеРаботыСистемы();
#КонецЕсли
// Конец СтандартныеПодсистемы   

//// **** Фунт ************   //так не получится теперь

ТекПользователь = Пользователи.АвторизованныйПользователь();

Если Строка(ТекПользователь) = "ТСД1" или Строка(ТекПользователь) = "Администратор" Тогда
ОкноТСД = ПолучитьФорму("Обработка.ТСД_РабочийСтол.Форма.Форма");
ОкноТСД.Открыть();
КонецЕсли;

//
//// **********************

КонецПроцедуры


Ошибка инициализации модуля: МодульУправляемогоПриложения
по причине:
{МодульУправляемогоПриложения(88,20)}: Переменная не определена (Пользователи)
ТекПользователь = <<?>>Пользователи.АвторизованныйПользователь();
[ОшибкаКомпиляцииВстроенногоЯзыка]

alexandr_ll

Funt432286, Раньше у вас в конфигурации был общий модуль "ПользователиКлиентСервер", теперь изменили название этого общего модуля. Сделайте глобальный поиск строки "ТекущийПользователь()" и найдите, в каком теперь общем модуле эта конструкция находится.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск