Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 мая 2024, 14:46

Убрать название "Таблица" из печатной формы

Автор Sasha1C, 23 янв 2024, 10:52

0 Пользователей и 1 гость просматривают эту тему.

Sasha1C

Подскажите пожалуйста как убрать название "Таблица" в печатной форме. В коде название "таблица" нигде не фигурирует. Если будут предложения по улучшению существующего кода буду только рад. Заранее  всем спасибо.
Процедура Печать(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
Макет = Документы.ЗаявкаНаТранспорт.ПолучитьМакет("Печать");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗаявкаНаТранспорт.Дата КАК Дата,
| ЗаявкаНаТранспорт.Номер КАК Номер,
| ЗаявкаНаТранспорт.Покупатель КАК Покупатель,
| ЗаявкаНаТранспорт.ТранспортноеСредство КАК ТранспортноеСредство,
| ЗаявкаНаТранспорт.Водитель КАК Водитель,
| ЗаявкаНаТранспорт.ПервыйГрузчик КАК ПервыйГрузчик,
| ЗаявкаНаТранспорт.СостояниеЗаказа КАК СостояниеЗаказа,
| ЗаявкаНаТранспорт.ВторойГрузчик КАК ВторойГрузчик,
| ЗаявкаНаТранспорт.Километраж КАК Километраж,
| ЗаявкаНаТранспортДоставляемыеТовары.Номенклатура КАК Номенклатура,
| ЗаявкаНаТранспортДоставляемыеТовары.Количество КАК Количество
,
| ЗаявкаНаТранспортДоставляемыеТовары.Цена КАК Цена,
| ЗаявкаНаТранспортДоставляемыеТовары.Сумма КАК Сумма
|ИЗ
| Документ.ЗаявкаНаТранспорт.ДоставляемыеТовары КАК ЗаявкаНаТранспортДоставляемыеТовары
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаявкаНаТранспорт КАК ЗаявкаНаТранспорт
| ПО ЗаявкаНаТранспортДоставляемыеТовары.Ссылка = ЗаявкаНаТранспорт.Ссылка
|ГДЕ
| ЗаявкаНаТранспорт.Ссылка В(&Ссылка)";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();


Если ТабДок.Области.Количество() > 0 Тогда
ТабДок.Очистить();
КонецЕсли;

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");


Если Выборка.Следующий()  Тогда
ОбластьЗаголовок.Параметры.ТекстЗаголовка = "Накладная   "  + Выборка.Номер;
ТабДок.Вывести(ОбластьЗаголовок);

    ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
  ОбластьШапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(ОбластьШапка);

ОбластьОбщиеДанные= Макет.ПолучитьОбласть("ОбщиеДанные");
ОбластьОбщиеДанные.Параметры.Заполнить(Выборка);
ТабДок.Вывести(ОбластьОбщиеДанные);

КонецЕсли;

Пока Выборка.Следующий() Цикл

ОбластьСписокТоваров = Макет.ПолучитьОбласть("СписокТоваров");
ОбластьСписокТоваров.Параметры.Заполнить(Выборка);
ТабДок.Вывести(ОбластьСписокТоваров);

КонецЦикла;

КонецПроцедуры

LexaK

Sasha1C, это просто имя окна! чем оно мешает?

его можно изменить, ищите у себя в коде где производится вывод вашей таблицы

ВашТабДок.Показать(!!!); //вот в этой команде можно задать нужное имя или вообще убрать
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск