Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 июн 2024, 17:08

Дважды показывает колонку в печатной формы "ПриходнаяНакладная"

Автор khrystallaimbat~, 23 янв 2024, 06:50

0 Пользователей и 1 гость просматривают эту тему.

khrystallaimbat~

Здравствуйте уважаемые форумчане, помогите исправить ошибку в печатной форме "Приходная Накладная".
Суть ошибки заключается в том, что два раза показывает колонку "МатериалыШапка"

Думаю ошибка в коде
Процедура Печать(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
Макет = Документы.ПриходнаяНакладная.ПолучитьМакет("Печать");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ПриходнаяНакладная.Дата,
| ПриходнаяНакладная.Номер,
| ПриходнаяНакладная.Поставщик,
| ПриходнаяНакладная.Склад,
| ПриходнаяНакладная.Материалы.(
| НомерСтроки,
| Материал,
| Количество,
| Цена,
| Сумма,
| НаборСвойств
| )
|ИЗ
| Документ.ПриходнаяНакладная КАК ПриходнаяНакладная
|ГДЕ
| ПриходнаяНакладная.Ссылка В (&Ссылка)";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
Шапка = Макет.ПолучитьОбласть("Шапка");
ОбластьМатериалыШапка = Макет.ПолучитьОбласть("МатериалыШапка");
ОбластьМатериалы = Макет.ПолучитьОбласть("Материалы");
ОбластьИтог = Макет.ПолучитьОбласть("Всего");
ТабДок.Очистить();

ВставлятьРазделительСтраниц = Ложь;
Пока Выборка.Следующий() Цикл
Если ВставлятьРазделительСтраниц Тогда
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

ТабДок.Вывести(ОбластьЗаголовок);

Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());

ТабДок.Вывести(ОбластьМатериалыШапка);
ВыборкаМатериалы = Выборка.Материалы.Выбрать(); 
СуммаИтог = 0;           
ТабДок.Вывести(ОбластьМатериалыШапка);
ВыборкаМатериалы = Выборка.Материалы.Выбрать();
Пока ВыборкаМатериалы.Следующий() Цикл
ОбластьМатериалы.Параметры.Заполнить(ВыборкаМатериалы);
ТабДок.Вывести(ОбластьМатериалы, ВыборкаМатериалы.Уровень()); 
СуммаИтог = СуммаИтог + ВыборкаМатериалы.Сумма;
КонецЦикла;
ОбластьИтог.Параметры.ВсегоПоДокументу = СуммаИтог;
ТабДок.Вывести(ОбластьИтог);


ВставлятьРазделительСтраниц = Истина;
КонецЦикла;
//}}
КонецПроцедуры

bsn-chita

2 раза область выводите.
ТабДок.Вывести(ОбластьМатериалыШапка);

Теги: pomow 

Похожие темы (5)

Рейтинг@Mail.ru

Поиск