Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 июн 2024, 17:14

Передача Параметров в из управляемой формы в управляемую форму

Автор Vasylii, 15 дек 2023, 16:48

0 Пользователей и 1 гость просматривают эту тему.

Vasylii

Суть в том что у меня данные есть на одной форме их я загоняю в структуру и пытаюсь передать на другую форму, через процедуру октрыть форму они не передаются почему-то, попробовал через обработку оповщения он открывает обработку оповещения формы источника, уже 1.5 часа сижу не могу понять в чем дело
в первой форме
&НаСервере
Функция ОтборыДляФормы()

СтруктураПараметров = Новый Структура;
СтруктураПараметров.Вставить("СсылкаНаСделку",ЭтотОбъект.Объект.Ссылка);
СтруктураПараметров.Вставить("Бренд",ЭтотОбъект.Объект.СРМ_Бренд);
СтруктураПараметров.Вставить("СписокСотрудниковПодразделения",Пользователи.ТекущийПользователь());

Возврат СтруктураПараметров;

КонецФункции

&НаКлиенте
Процедура СРМ_CRM_КонтактноеЛицоНачалоВыбораВместо(Элемент, ДанныеВыбора, СтандартнаяОбработка)  //бит_Козырев 04.11.23

СтандартнаяОбработка = Ложь;
ПараметрыОтборов = ОтборыДляФормы();         
Оповестить("Справочник.КонтактныеЛицаПартнеров.Форма.СРМ_ФормаВыбораПоБренду", ПараметрыОтборов, ЭтотОбъект);
ОткрытьФорму("Справочник.КонтактныеЛицаПартнеров.Форма.СРМ_ФормаВыбораПоБренду",ПараметрыОтборов,,ЭтаФорма);

КонецПроцедуры

в 2 форме
&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
Если ИмяСобытия = "Справочник.CRM_3_СделкиСКлиентами.ФормаЭлемента" Тогда

КонецЕсли;
КонецПроцедуры

LexaK

Vasylii,  а зачем сейчас все в одну кучу смешали?
(и оповещение неправильно настроено...)
СП умеете запускать и читать?

если помогло нажмите: Спасибо!

Vasylii

LexaK, тестировал по этому все одну кучу, в оповещении что не так (1.имя события, 2.параметры, 3.источник)

LexaK

имена событий разные, и кода обработки данных нет

"Справочник.КонтактныеЛицаПартнеров.Форма.СРМ_ФормаВыбораПоБренду"
"Справочник.CRM_3_СделкиСКлиентами.ФормаЭлемента"
если помогло нажмите: Спасибо!

Похожие темы (5)

Рейтинг@Mail.ru

Поиск