Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июн 2024, 06:20

Некорректно работает выбор из списка в браузере

Автор Владимир Фоменков, 05 дек 2023, 13:44

0 Пользователей и 1 гость просматривают эту тему.

Владимир Фоменков

Добрый день, коллеги. Наткнулся на проблему, прошу помочь с решением. В веб-клиенте при выборе поля с режимом "Выбор из списка" открывается одновременно выпадающий список и отдельное окно с тем же списком. Выбирать можно и там и там, выбор применяется. В током клиенте открывается только выбор из списка.


Код:
&НаКлиенте
Процедура СписокЗапросовСтатусЗапросаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
   СтандартнаяОбработка = Ложь;
   ДанныеВыбора = Новый СписокЗначений;
   СтрСпискаЗапросов = Элементы.СписокЗапросов.ТекущиеДанные;
   Если СтрСпискаЗапросов.СтатусЗапроса = ПредопределенноеЗначение("Перечисление.Запр_СтатусыЗапроса.Отменено") Тогда   
      ДанныеВыбора.Добавить(ПредопределенноеЗначение("Перечисление.Запр_СтатусыЗапроса.НеПринят"));
      ДанныеВыбора.Добавить(ПредопределенноеЗначение("Перечисление.Запр_СтатусыЗапроса.Архив"));
   ИначеЕсли СтрСпискаЗапросов.СтатусЗапроса = ПредопределенноеЗначение("Перечисление.Запр_СтатусыЗапроса.ПолученОтвет") Тогда
      ДанныеВыбора.Добавить(ПредопределенноеЗначение("Перечисление.Запр_СтатусыЗапроса.Отменено"));
      Если ТипЗнч(СтрСпискаЗапросов.Номенклатура) = ТИП("Строка") Тогда
         ДанныеВыбора.Добавить(ПредопределенноеЗначение("Перечисление.Запр_СтатусыЗапроса.ВноситсяНоменклатура"));
      Иначе
         ДанныеВыбора.Добавить(ПредопределенноеЗначение("Перечисление.Запр_СтатусыЗапроса.ГотовоКЗаказу"));   
      КонецЕсли;   
   Иначе
      ДанныеВыбора.Добавить(ПредопределенноеЗначение("Перечисление.Запр_СтатусыЗапроса.Отменено"));
   КонецЕсли;
   ДопПараметры = Новый Структура;
   //ДопПараметры.Вставить("НомерСтроки", СтрСпискаЗапросов.НомерСтроки -1);
   ОписаниеОповещения = Новый ОписаниеОповещения("ОбработкаОповещенияСтатусВСписке",ЭтаФорма,ДопПараметры);
   ПоказатьВыборИзСписка(ОписаниеОповещения,ДанныеВыбора,Элемент);
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаОповещенияСтатусВСписке(ЗначениеВыбора, ДопПараметры) Экспорт
   
   Если НЕ ЗначениеВыбора = Неопределено Тогда
      СтрСпискаЗапросов = Элементы.СписокЗапросов.ТекущиеДанные;
      СтрСпискаЗапросов.СтатусЗапроса = ЗначениеВыбора.Значение;             
   КонецЕсли
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск