Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 мая 2024, 09:51

Ошибка формулы расчета для реквизита ТЧ

Автор ksks, 18 ноя 2023, 19:09

0 Пользователей и 1 гость просматривают эту тему.

ksks

Здравствуйте. Подскажите, пожалуйста где ошибка.
есть ТЧ называется МаршрутныйЛистМото и реквизит ОтработаноМотоЧасов
есть ТЧ МотоРасходТоплива и реквизит ФактическийРасход
пытаюсь рассчитать фактический расход (его формула такая ОтработаноМотоЧасов*норма расхода)

мой код

&НаКлиенте
Процедура РасчетСтрокаМотоРасходТопливаФактическийРасходПриИзменении()
СтрРасчета=Элементы.МотоРасходТоплива.ТекущиеДанные;
СтрРасчета1=Элементы.МаршрутныйЛистМото.ТекущиеДанные;
СтрРасчета.ФактическийРасход=СтрРасчета1.ОтработаноМотоЧасов*Объект.НормаРасхода ;

КонецПроцедуры

&НаКлиенте
Процедура МаршрутныйЛистМотоОтработаноЧасовПриИзменении(Элемент)
РасчетСтрокаМотоРасходТопливаФактическийРасходПриИзменении();
КонецПроцедуры

&НаКлиенте
Процедура НормаРасходаПриИзменении(Элемент)
РасчетСтрокаМотоРасходТопливаФактическийРасходПриИзменении();
КонецПроцедуры

сохраняет код,а когда ввожу число в строку ОтработаноМотоЧасов ошибка ("Значение не является значением объектного типа (ФактическийРасход)
{Документ.ПутевойЛист.Форма.ФормаДокумента.Форма(131)}:СтрРасчета.ФактическийРас ход=СтрРасчета1.ОтработаноМотоЧасов*Объект.НормаРасхода;
{Документ.ПутевойЛист.Форма.ФормаДокумента.Форма(116)}:РасчетСтрокаМотоРасходТоп ливаФактическийРасходПриИзменении()

LexaK

ksks, при таком коде
СтрРасчета=Элементы.МотоРасходТоплива.ТекущиеДанные;
СтрРасчета1=Элементы.МаршрутныйЛистМото.ТекущиеДанные;

переменные СтрРасчетааи СтрРасчета1 могут принимать Значение Неопределено
а от Неопределено через точку значение получить нельзя!

переделывайте логику расчета (обхода строчек ТЧ) что бы не зависело от ТекущиеДанные
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск