Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 дек 2023, 23:24

1C 8.3. Как правильно переделать данный код с разными директивами?

Автор nasvyaze, 18 окт 2023, 14:14

0 Пользователей и 1 гость просматривают эту тему.

nasvyaze

Код:
&НаСервере
Процедура ПриОткрытииНаСервере()
ПараметрыФормы = Новый Структура("НачалоПериода, КонецПериода, Товар", '20091201000000', '20091231235959', Документы.Организации.НайтиПоНомеру("000000002",'20231018095113'));
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
ПриОткрытииНаСервере();
ОткрытьФорму("Справочник.НазванияОрганизации.Форма", ПараметрыФормы);
КонецПроцедуры

Выдает ошибку что ПараметрыФормы не найдено (логично).

Первый код не сможем использовать на клиенте, т.к. получаем ссылку (который выдаст ошибку на клиенте).
А второй код не сможем использовать на сервере, т.к. ОткрытьФорму не доступен на сервере.
Как правильно переделать данный код?

antoneus

&НаСервере
Функция ПараметрыФормы()
Возврат Новый Структура("НачалоПериода, КонецПериода, Товар", '20091201000000', '20091231235959', Документы.Организации.НайтиПоНомеру("000000002",'20231018095113'));
КонецФункции

&НаКлиенте
Процедура ПриОткрытии(Отказ)
ОткрытьФорму("Справочник.НазванияОрганизации.Форма", ПараметрыФормы()); 
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск