Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 фев 2024, 15:27

Иерархический список в ТаблицаЗначений

Автор maxxi, 19 сен 2023, 09:00

0 Пользователей и 1 гость просматривают эту тему.

maxxi

Здравствуйте, есть ТЗ с 5 колонками. Хочу разместить в колонку "Товары" иерархический список всеми группами и подгруппами как в фото.
Подскажите как это сделать.
Спасибо.

LexaK

как на снимке, это не ТЗ а ДЗ
если помогло нажмите: Спасибо!

maxxi

Пока мой запрос такого вида:
&НаСервере
Процедура Команда1НаСервере()
   
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Товары.Ссылка КАК Товар
        |ИЗ
        |    Справочник.Товары КАК Товары
        |ГДЕ
        |    НЕ Товары.НеАктивный
        |    И НЕ Товары.ПометкаУдаления
        |
        |УПОРЯДОЧИТЬ ПО
        |    Товар ИЕРАРХИЯ";
   
    ДеревоЗначении=Запрос.Выполнить().Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией);
   
    ДеревоЗнач=ЗначениеВРеквизитФормы(ДеревоЗначении,"ДЗ");
   
    Выборка = ДеревоЗнач.Выбрать();
   
    Пока Выборка.Следующий() Цикл
       
        //что писать сюда
           
    КонецЦикла;
   
КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
    Команда1НаСервере();
КонецПроцедуры

Но получаю ошибку такого вида:Фото.

antoneus

Ну так у дерева значений нет метода Выбрать, у него есть коллекция Строки, которую можно обходить рекурсивно.

//что писать сюда

Это пять! Нам нужно угадать, что вам нужно сделать?)

LexaK

Цитата: antoneus от 19 сен 2023, 11:08Это пять! Нам нужно угадать, что вам нужно сделать?)
зачем гадать? в первом посте автор показал картинку что ему нужно! не ужели по картинке не понятно?
если помогло нажмите: Спасибо!

LexaK

maxxi, одним запросом вы иерархию не построите!
используйте ДинамическийСписок там как раз в настройках можно указать вывод в виде дерева

если помогло нажмите: Спасибо!

maxxi

LexaK, Спасибо получилось, скажите пожалуйста, а как теперь соединить это все  с документами через запрос и разместить в других колонках например, колонка "КоличествоПродаж". Спасибо.

LexaK

maxxi, это не с документами надо связывать, а с РН (регистром накопления) какой он там у вас по продажам/реализациям ...
используйте левое соединение, берите оборот (какой? весь? за период?)
(в учебниках полно примеров: вывод ОСтатков номенклатуры в списке товаров, в справочнике Номенклатура)
если помогло нажмите: Спасибо!

maxxi

LexaK, запросом брал, но с динамической списком работаю в первые
ОК попробую

LexaK

maxxi, ДС это тоже запрос, откройте свойства ДС, на закладке поставьте галочку Произвольный
затем сможете открыть сам запрос (Настройка списка: Открыть) и в нем добавить левым соединением нужные данные
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск