Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 фев 2024, 10:08

Отфильтровать список отчетов в соответствии с доступными ролями.

Автор acelysX, 23 июн 2023, 10:43

0 Пользователей и 1 гость просматривают эту тему.

acelysX

Необходимо отфильтровать список отчетов в соответствии с доступными ролями в базе
Список уже готов, но не получается отфильтровать список отчетов
Подскажите, что нужно поправить
Код &НаСервере
Процедура ВыборОтчетовНаСервере()
ФормаВыбора = Справочники.Пользователи.ПолучитьФормуВыбора();
Результат = ФормаВыбора.ОткрытьМодально();
СписокОтчетов = Новый СписокЗначений;
Если РольДоступна("АдминистраторСистемы") Или РольДоступна("ПросмотрОтчет1") Тогда
Для каждого Отчет Из Метаданные.Отчеты Цикл
ЗначениеСписка = СписокОтчетов.Добавить(Отчет);
КонецЦикла;
КонецЕсли;
ВыбранныйЭлемент = СписокОтчетов.ВыбратьЭлемент("Выберите отчет", СписокОтчетов[0]);
Если ВыбранныйЭлемент <> Неопределено Тогда
Отчеты[ВыбранныйЭлемент.Значение.Имя].ПолучитьФорму().Открыть();
КонецЕсли;
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск