Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 мая 2024, 10:12

Создание документа программно

Автор Funt432286, 25 июл 2023, 09:55

0 Пользователей и 1 гость просматривают эту тему.

Funt432286

Всем доброго времени суток!

Первый раз столкнулся с такой проблемкой! Допиливаю 1с КА, перевел на обычные формы!
Есть обработка, с нажатием кнопки пытаюсь создать новый документ! Всегда все работала в других конфигурациях отлично!
Сейчас при создании документа вылетает ошибка:

Значение не является значением объектного типа (Ф_ЗаявкаНаСклад)
{ВнешняяОбработка.Ф_ЗаявкаНаСклад.Форма.Ф_ЗаявкаНаСклад.Форма(109)}: ДокЗаявка = Документы.Ф_ЗаявкаНаСклад.СоздатьДокумент();

Код процедуры создания на форме:
ДокЗаявка = Документы.Ф_ЗаявкаНаСклад.СоздатьДокумент();
ДокЗаявка.Дата = ТекущаяДата();

ДокЗаявка.Записать();


Подскажите пожалуйста, в чем прикол! Очень срочно нужна помощь!


LexaK

Funt432286,
ВнешняяОбработка.Ф_ЗаявкаНаСклад.Форма.Ф_ЗаявкаНаСклад.Форма
а что это у вас тут "двоит" ?
Ф_ЗаявкаНаСклад.Форма
Ф_ЗаявкаНаСклад.Форма
- два раза подряд?
если помогло нажмите: Спасибо!

alexandr_ll

Funt432286, Проверяйте имя создаваемого документа в конфигураторе

Funt432286

Цитата: LexaK от 25 июл 2023, 10:00Funt432286,
ВнешняяОбработка.Ф_ЗаявкаНаСклад.Форма.Ф_ЗаявкаНаСклад.Форма
а что это у вас тут "двоит" ?
Ф_ЗаявкаНаСклад.Форма
Ф_ЗаявкаНаСклад.Форма
- два раза подряд?

Это били одинаковые имена у документа и у оброботке, я их поменял чтобы было различие.

Цитата: alexandr_ll от 25 июл 2023, 10:04Funt432286, Проверяйте имя создаваемого документа в конфигураторе

Имя сейчас вроде правильное. Формировал команду из автозаполнения данных
Но такое ощущение что у внешней обработке нет доступа к формированию и изменению данных и документов

Значение не является значением объектного типа (Ф_ДокЗаявкаНаСклад)
{Обработка.Ф_ЗаявкаНаСклад.Форма.Ф_ЗаявкаНаСклад.Форма(109)}:   ДокЗаявка = Документы.Ф_ДокЗаявкаНаСклад.СоздатьДокумент();

LexaK

весь код выкладывайте!
в самом конфигураторе, в разделе Документы, такой документ: Ф_ДокЗаявкаНаСклад есть ?

и все это в контексте сервера делаете?
&НаСервере ?
если помогло нажмите: Спасибо!

Funt432286

LexaK,
форма обычная, не управляемая
Процедура СформироватьЗаявку(Кнопка)

ДокЗаявка = Документы.Ф_ДокЗаявкаНаСклад.СоздатьДокумент();
ДокЗаявка.Дата = ТекущаяДата();

ТабДокЗаявка = Новый ТаблицаЗначений;
ТабДокЗаявка = ДокЗаявка.ТЧ_ЗаказыКлиентов;
Для Каждого Стр из ОбработкаОбъект.ТЧ_ЗаказыКлиентов Цикл

Если Стр.Отгрузка = Истина Тогда
ТабДокЗаявка.Заказчик = Стр.Заказчик;
ТабДокЗаявка.Номенклатура = Стр.Номенклатура;
ТабДокЗаявка.Количество = Стр.Количество;
ТабДокЗаявка.ТранспортКомпания = Стр.ТранспортКомпания;
ТабДокЗаявка.АдресДоставки = Стр.АдресДоставки;
ТабДокЗаявка.Плательщик = Стр.Плательщик;
ТабДокЗаявка.ТипДоставки = Стр.ТипДоставки;
ТабДокЗаявка.ТипУпаковки = Стр.ТипУпаковки;
ТабДокЗаявка.Документы = Стр.Документы;
КонецЕсли;
КонецЦикла;

ДокЗаявка.Записать();

КонецПроцедуры

LexaK

Funt432286, в самом конфигураторе такой документ есть?
Документы.Ф_ДокЗаявкаНаСклад?

на форме реквизита с именем Документы - не заводили? (возможно переопределили ключевое слово!)

внимательно ответьте на эти вопросы.
если помогло нажмите: Спасибо!

Funt432286

LexaK, на форме есть реквизит табличной части Документы ))))
сейчас поменяю реквизит, посмотрю что будет! но должно быть счастье ))


Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск