Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июн 2024, 06:15

Заполнение атрибута при формировании ПКО 1С:Комплексная автоматизация 2.5

Автор yoshicity, 16 июл 2023, 19:37

0 Пользователей и 1 гость просматривают эту тему.

yoshicity

Здравствуйте.
Не получается достать значение для ПКО.Кассы = , в выемке нет информации по кассе с которой закрывалась смена.
Знаю что в настройках РМК указывается значение кассы для определенного фискального устройства (у одной организации может быть несколько касс).
 

&После ("ВыполнитьАвтоматическуюИнкассациюДС")
Процедура Автоматическое_СозданиеПКО_ПриЗакрытииСмены(КассаККМ, ОшибкаПриСнятииZОтчетам) Экспорт

    // Запрос для поиска последней выемки денежных средств
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ ПЕРВЫЕ 1
        |   ВыемкаДенежныхСредствИзКассыККМ.Ссылка КАК Ссылка
        |ИЗ
        |   Документ.ВыемкаДенежныхСредствИзКассыККМ КАК ВыемкаДенежныхСредствИзКассыККМ
        |ГДЕ
        |   ВыемкаДенежныхСредствИзКассыККМ.Проведен
        |УПОРЯДОЧИТЬ ПО
        |   Дата УБЫВ";

    // Выполняем запрос и получаем ссылку на последнюю проведенную выемку
    РезультатЗапроса = Запрос.Выполнить();
    Если РезультатЗапроса.Пустой() Тогда
        Возврат;
    КонецЕсли;
    Выборка = РезультатЗапроса.Выбрать();
    Выборка.Следующий();
    ПоследняяВыемка = Выборка.Ссылка;

    Если ЗначениеЗаполнено(ПоследняяВыемка) Тогда

        // Создаем объект ПКО и заполняем ПКО на основании последней выемки
        ПКО = Документы.ПриходныйКассовыйОрдер.СоздатьДокумент();
        ПКО.ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ПоступлениеДенежныхСредствИзКассыККМ;
      ПКО.ДокументОснование = ПоследняяВыемка.Ссылка;
      ПКО.КассаККМ = ПоследняяВыемка.КассаККМ;
      ПКО.Организация = ПоследняяВыемка.Организация;
      ПКО.Дата = ТекущаяДата();
        ПКО.СуммаДокумента = ПоследняяВыемка.СуммаДокумента;
        ПКО.Валюта = ПоследняяВыемка.Валюта;
        ПКО.Кассир = ПоследняяВыемка.Кассир;
      
      // Запрос для получения ссылки на кассу                 

      //ПКО.Касса =
        // Запись и проведение ПКО
      ПКО.Записать(РежимЗаписиДокумента.Проведение);
      Сообщить("ПКО успешно создан на основе последней выемки денежных средств.");
    КонецЕсли;

КонецПроцедуры


yoshicity

спасибо что не ответили, я напряг свой крошечный мозг и справился

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск