Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 мая 2024, 15:06

1С 8.3. Как обнулить ресурс резерв регистра накопления?

Автор gulnyr, 24 июн 2023, 00:02

0 Пользователей и 1 гость просматривают эту тему.

gulnyr

Как обнулить ресурс резерв регистра накопления? (которые уже были в движении)

Screenshot_69.png

Afinogen

НаборЗаписей()
Процедура ОбнулениеРегистра(Ссылка)
 Набор = РегистрыНакопления.ОстаткиТоваровКомпании.СоздатьНаборЗаписей()
 Набор.Отбор.Регистратор.Установить(Ссылка);
 Набор.Прочитать();
 Если Набор.Выбран() Тогда
  Для Каждого Стр ИЗ набор Цикл
    Стр.Резерв2=0;
  КонецЦикла;
  Набор.Записать();
 КонецЕсли;
КонецПроцедуры
и лучше все это делать заграв в НачатьТранзакцию() и ЗафиксироватьТранзакцию()


Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск