Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 июн 2024, 16:46

Заполнение реквизита при изменении.

Автор aboba174, 24 мая 2023, 11:14

0 Пользователей и 1 гость просматривают эту тему.

aboba174

Здравствуйте.  :zebzdr:

Есть документ Запись, хочу чтобы при выборе сотрудника в реквизит кабинет автоматически подставлялся номер кабинета для своего сотрудника.

Кабинет у меня отдельный справочник. А также в справочнике сотрудник есть реквизит кабинет со ссылкой на справочник(кабинет).

Сделал процедуру При изменение сотрудника, а как вытащить не знаю. Подскажите.


LexaK

aboba174, как-то странно вы изучаете 1С! Свои Конфигурации пишите! а как получить значение реквизита справочника - не знаете
несколько вариантов есть, самый простой чере точку
пример

лкКабинет = Сотрудник.Кабинет; //что здесь сложного?  :dfbsdfbsdf:
если помогло нажмите: Спасибо!

aboba174

LexaK, Не, мне ж надо как-то объявитьь что такое Кабинет и сотрудник.

Я вот пишу например Объект.Кабинет = ...;

Он же не знает что такое Сотрудник.Кабинет

LexaK

Цитата: aboba174 от 24 мая 2023, 11:24LexaK, Не, мне ж надо как-то объявитьь что такое Кабинет и сотрудник.

Я вот пишу например Объект.Кабинет = ...;

Он же не знает что такое Сотрудник.Кабинет
значит Кабинет в Объекте вы нашли! а Сотрудника?

Объект.Кабинет = Объект.Сотрудник.Кабинет;
если помогло нажмите: Спасибо!

aboba174

LexaK, Поле объекта не обнаружено (Кабинет)
{Документ.Запись.Форма.ФормаДокумента.Форма(75)}:    Объект.Кабинет = Объект.Сотрудник.Кабинет;  :btbzdb:

antoneus

Цитата: aboba174 от 24 мая 2023, 11:40LexaK, Поле объекта не обнаружено (Кабинет)
{Документ.Запись.Форма.ФормаДокумента.Форма(75)}:    Объект.Кабинет = Объект.Сотрудник.Кабинет;  :btbzdb:

на клиенте не взлетит

aboba174

antoneus, Надо в модуле объекта создавать или новый общий модуль?

LexaK

aboba174, всю процедуру СотрудникПриИзменении сюда выложите
если помогло нажмите: Спасибо!

aboba174

LexaK,

&НаКлиенте
Процедура СотрудникПриИзменении(Элемент)
     Объект.Кабинет = Объект.Сотрудник.Кабинет;
КонецПроцедуры

LexaK

aboba174, попробуйте так
&НаКлиенте
Процедура СотрудникПриИзменении(Элемент)
     ОбновитьКабинетНаСервере();
 КонецПроцедуры
 
&НаСервере
Процедура ОбновитьКабинетНаСервере()
     Объект.Кабинет = Объект.Сотрудник.Кабинет;
 КонецПроцедуры
 


если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск