Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 мая 2024, 11:41

Назначение действия на кнопку в форме документа

Автор Dmitrii_VVV, 22 мая 2023, 17:22

0 Пользователей и 1 гость просматривают эту тему.

Dmitrii_VVV

Коллеги! Помогите советом начинающему...

Задача: При выборе поля Валюта (Доллар, Евро или Рубль)и нажатии на кнопку Валюта 1, что бы заполнялось поле Курс

Есть РС Курсы валют с измерением Валюта и ресурсом Курс, Справочник Валюта и Документ с формой которого работаем.

Необходимо назначить действие для кнопки, что бы вся эта красота заработала

Помогите пожалуйста с кодом, с чего начать

&НаКлиенте
Процедура Валюта1(Команда)
    Валюта1НаСервере();
       
   
КонецПроцедуры

&НаСервере
Процедура Валюта1НаСервере()
    // Вставить содержимое обработчика.
КонецПроцедуры
Неверный ID вложения.

LexaK

Dmitrii_VVV, а зачем вам кнопки Валюта1 и Валюта2

у поля валюта, тоже есть обработчики событий, используйте событие ПриИзменении()
и у вас, каждый раз при выборе валюты, тут-же будет показываться ее курс!!! Без всяких нажатий кнопок!
Внимание! Реквизиту формы Курс, задайте тип Число!!!

&НаКлиенте
Процедура ВалютаПриИзменении(Элемент)

лкКурс = ПолучитьКурсВалютыНаСервере();
    ПоказатьПредупреждение(,"Курс: " + лкКурс, 10);
Курс = лкКурс;

КонецПроцедуры

&НаСервере
Функция ПолучитьКурсВалютыНаСервере()
                                                                           
лкОтбор = Новый Структура("Валюта", Валюта);                                                                           
лкРезультат = РегистрыСведений.КурсыВалют.СрезПоследних(Объект.Дата,лкОтбор);
Попытка
лкКурс = лкРезультат[0].Курс;
Исключение
лкОшибка = ОписаниеОшибки();
Сообщить(лкОшибка);
лкКурс = 0;
КонецПопытки;
Возврат лкКурс;

КонецФункции
если помогло нажмите: Спасибо!

Dmitrii_VVV

Цитата: LexaK от 22 мая 2023, 17:52Dmitrii_VVV, а зачем вам кнопки Валюта1 и Валюта2

у поля валюта, тоже есть обработчики событий, используйте событие ПриИзменении()
и у вас, каждый раз при выборе валюты, тут-же будет показываться ее курс!!! Без всяких нажатий кнопок!
Внимание! Реквизиту формы Курс, задайте тип Число!!!


Не совсем понял ваш, код и как его применить в моём случае. Будем разбираться

Спасибо!

LexaK

Dmitrii_VVV,
ЦитироватьНе совсем понял ваш, код и как его применить
1.скопировать в свою форму
2.связать/назначить событие ПриИзменении с процедурой
3.Проверить и заменить (при необходимости) имена реквизитов на те которые используются у вас
4.сохранить и применить изменения
5.Запустить программу на выполнение.
если помогло нажмите: Спасибо!

Dmitrii_VVV

Цитата: LexaK от 23 мая 2023, 10:001.скопировать в свою форму
2.связать/назначить событие ПриИзменении с процедурой
3.Проверить и заменить (при необходимости) имена реквизитов на те которые используются у вас
4.сохранить и применить изменения
5.Запустить программу на выполнение.


Спасибо за труд!

А есть более простое исполнение задачи?
Я ещё на начальном этапе просто

LexaK

Dmitrii_VVV,
ЦитироватьА есть более простое исполнение задачи?
конечно есть!
любую задачу можно решить разными способами, какие-то из них, сложные, другие - проще.
(тут кто во что горазд)
если помогло нажмите: Спасибо!

Dmitrii_VVV

Цитата: LexaK от 23 мая 2023, 17:50Dmitrii_VVV,
ЦитироватьА есть более простое исполнение задачи?
конечно есть!
любую задачу можно решить разными способами, какие-то из них, сложные, другие - проще.
(тут кто во что горазд)


Вас не затруднит показать более простой способ ?

LexaK

Цитата: Dmitrii_VVV от 24 мая 2023, 09:59Вас не затруднит показать более простой способ ?
Вот самый простой способ! Вам даже конфигуратор открывать не надо будет!!!
Фриланс размещаете свою задачу, ценник (10 или 20 т.р. зависит от сложности)
и ни каких забот! 
если помогло нажмите: Спасибо!

Dmitrii_VVV

LexaK, Спасибо, но если за кэш искать помощь в решении задачи, то можно куда дешевле 10-20к найти  ;)

LexaK

Цитата: Dmitrii_VVV от 24 мая 2023, 11:25LexaK, Спасибо, но если за кэш искать помощь в решении задачи, то можно куда дешевле 10-20к найти  ;)
Не знаю, не пробовал! Это я с запасом заложился  :D  , опять же упоминание сложности задачи было.
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск