Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
15 июл 2024, 04:29

Иерархия

Автор Nosferatu112, 19 мая 2023, 17:06

0 Пользователей и 1 гость просматривают эту тему.

Nosferatu112

Всем привет, кто подскажет почему при переключении иерархии в одиночную она не изменяеться а в иерархмическую наслаиваеться друг на друга

&НаКлиенте
Процедура ВидИерархия(Команда)

Если Не ВидИерархия Или ОтображатьСтруктуруПредприятия Тогда
ВидИерархия = Истина;
ОтображатьСтруктуруПредприятия = Ложь;
ОбработатьИзменениеВидаСписка();
КонецЕсли;

ПодключитьОбработчикОжидания("ПриИзмененииСохраняемойНастройки", 0.2, Истина);

КонецПроцедуры 

&НаКлиенте
Процедура ВидСписок(Команда)

Если ВидИерархия Или ОтображатьСтруктуруПредприятия Тогда

ВидИерархия = Ложь;
ОтображатьСтруктуруПредприятия = Ложь;

ОбщегоНазначенияКлиентСервер.УдалитьЭлементыГруппыОтбораДинамическогоСписка(Список, "МестоВСтруктуреПредприятия");

ОбработатьИзменениеВидаСписка();

КонецЕсли;

ПодключитьОбработчикОжидания("ПриИзмененииСохраняемойНастройки", 0.2, Истина);

КонецПроцедуры

&НаКлиентеНаСервереБезКонтекста
Процедура ОбработатьОтображениеРежимаИерархии(Форма)

Элементы = Форма.Элементы;

Элементы.ФормаВидИерархия.Пометка = Форма.ВидИерархия И Не Форма.ОтображатьСтруктуруПредприятия;
Элементы.ФормаВидСписок.Пометка = Не Форма.ВидИерархия И Не Форма.ОтображатьСтруктуруПредприятия;

ОбщегоНазначенияКлиентСервер.УстановитьСвойствоЭлементаФормы(Элементы,
"ВидСтруктураПредприятия", "Пометка", Форма.ОтображатьСтруктуруПредприятия)
;

ЭлементГруппировки = Неопределено;
Если Элементы.ФормаВидИерархия.Пометка = Истина Тогда
Элементы.Подразделение.Видимость = Ложь;
Элементы.ДолжностьРодитель.Видимость = Истина;
Иначе
Элементы.Подразделение.Видимость = Истина;
Элементы.ДолжностьРодитель.Видимость = Ложь;
КонецЕсли;
Для каждого Элемент Из Форма.Список.Группировка.Элементы Цикл

Если СокрЛП(Элемент.Поле) = "Подразделение" Тогда
ЭлементГруппировки = Элемент;

Прервать;
КонецЕсли;

КонецЦикла;

Если ЭлементГруппировки = Неопределено Тогда

ЭлементГруппировки = Форма.Список.Группировка.Элементы.Добавить(Тип("ПолеГруппировкиКомпоновкиДанных"));
ЭлементГруппировки.Поле = Новый ПолеКомпоновкиДанных("Подразделение.Родитель");
ЭлементГруппировки1 = Форма.Список.Группировка.Элементы.Добавить(Тип("ПолеГруппировкиКомпоновкиДанных"));
ЭлементГруппировки1.Поле = Новый ПолеКомпоновкиДанных("Подразделение");
КонецЕсли;

ЭлементГруппировки.Использование = Форма.ВидИерархия;
ЭлементГруппировки1.Использование = Форма.ВидИерархия;


КонецПроцедуры

Это вид изначально при открытии
ШтаткаИзначальная.png
Это иерархический вид
ШтаткаИерархия.png
Когда меняю на однруровнеывый остается такой же
И когда опять с одноуровнего ставлю иерархический
ШтаткаИерархия2.png
Они наслаиваються 

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск