Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июн 2024, 06:42

В зависимости от значения реквизита, открывать определенную форму элемента справочника.

Автор steeld, 04 мая 2023, 14:38

0 Пользователей и 1 гость просматривают эту тему.

steeld

У меня есть справочник Номенклатура, в ней есть реквизит "тип". В зависимости от выбора "типа" нужно открыть разные формы элемента.
Тип это перечисления

LexaK

откройте модуль менеджера справочника, в нес создайте процедуру ОбработкаПолученияФормы
в ней анализируйте Тип и возвращайте нужную форму
пример нужен?
если помогло нажмите: Спасибо!

steeld


LexaK

steeld, вот типовой пример
// Процедура - обработчик получения формы справочника.
//
// Параметры:
// ВидФормы - Строка - Вид формы справочника.
// Параметры - Структура - Параметры, переданные для формы.
// ВыбраннаяФорма - Строка - Имя открываемой формы справочника.
// ДополнительнаяИнформация - Строка - Дополнительная информация.
// СтандартнаяОбработка - Булево - Признак стандартной обработки.
//
Процедура ОбработкаПолученияФормы(ВидФормы, Параметры, ВыбраннаяФорма, ДополнительнаяИнформация, СтандартнаяОбработка)
Если ВидФормы = "ФормаОбъекта" Тогда
Если Параметры.Свойство("Ключ") Тогда
Если Параметры.Ключ.Предопределенный Тогда
// Запрещаем редактировать предопределенный элемент.
СтандартнаяОбработка = Ложь;
ВыбраннаяФорма = "ФормаЭлемента";
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецПроцедуры // ОбработкаПолученияФормы()

если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск