Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июн 2024, 07:07

Внешняя обработка заполнения табличных частей. Не заполняет ((( УТ 10.3

Автор Плевел Тратилин, 26 апр 2023, 12:27

0 Пользователей и 1 гость просматривают эту тему.

Плевел Тратилин

Друзья, коллеги, братья.
Внешняя обработка заполнения табличных частей. ЗАполняет всё, кроме документа установки цен номенклатуры. ПРичем если вызываю принудительно через форму обработки специально для этого создданную, то всё норм. Если как внешнюю обработку заполнения таб. части, то ПОСТУПЛЕНИЕ И ЗАКАЗ КУДА Я ЁЁ ПРИКРУЧИВАЮ ЗАПОЛНЯЕТ, А УСТАНОВКУ ЦЕН НИ В КАКУЮ ((((
Куда ковырять?


Процедура Инициализировать(Объект,Таблица,ТабИмя) Экспорт

УИД = Объект.Ссылка.УникальныйИдентификатор();
П = Новый Структура("УникальныйИдентификатор", УИД);
ОтборОбработка = ПолучитьФорму("Обработка.ПодборНоменклатурыПоОтбору.Форма",П);
ТБ = ПолучитьИзВременногоХранилища(ОтборОбработка.ОткрытьМодально());

Если НЕ ТипЗнч(Объект) = Тип("ДокументОбъект.УстановкаЦенНоменклатуры")Тогда

Для каждого Строчечка из ТБ Цикл
СТРОЧКСКА=Объект.Товары.Добавить();
ЗаполнитьЗначенияСвойств(СТРОЧКСКА, Строчечка);
СТРОЧКСКА.СтавкаНДС = Строчечка.Номенклатура.СтавкаНДС;
СТРОЧКСКА.ЕдиницаИзмерения = Строчечка.Номенклатура.ЕдиницаДляОтчетов;
СТРОЧКСКА.Коэффициент = Строчечка.Номенклатура.ЕдиницаДляОтчетов.Коэффициент;
КонецЦикла;
Иначе

Если  Объект.ТипыЦен.Количество() = 0 Тогда
СтрЦен = Объект.ТипыЦен.Добавить();
СтрЦен.ТипЦен = Справочники.ТипыЦенНоменклатуры.НайтиПоНаименованию("Закупочная");
КонецЕсли;
Инд = 0;


Для каждого Строчечка из ТБ Цикл

СТРОЧКСКА=Объект.Товары.Добавить();
ЗаполнитьЗначенияСвойств(СТРОЧКСКА, Строчечка);
СТРОЧКСКА.ТипЦен = Объект.ТипыЦен[0].ТипЦен;
СТРОЧКСКА.ЕдиницаИзмерения =  Строчечка.Номенклатура.ЕдиницаДляОтчетов;
СТРОЧКСКА.ИндексСтрокиТаблицыЦен = Инд;
Инд = Инд+1;
КонецЦикла;

КонецЕсли;


КонецПроцедуры




LexaK

Плевел Тратилин,
Повеселили однако, просто перл!  B)
Если НЕ ТипЗнч(ОБЪ) = Тип("ДокументОбъект.УстановкаЦенНоменклатуры")Тогда
Инициализировать (ОБЪ, ОБЪ.Товары, "Товары"); //одно и то-же
Иначе
Инициализировать (ОБЪ, ОБЪ.Товары, "Товары"); //одно и то-же
КонецЕсли;
может есть какой-то скрытый смысл?
если помогло нажмите: Спасибо!

Плевел Тратилин

LexaK, Уже нет этого )
И в этом случае работает! Когда запускаешь через форму самой внешней обработки! А смысл был. Вначале с третьим параметром эксперементировал!

LexaK

как вариант, в этой таблице ТБ - нет данных
ТБ = ПолучитьИзВременногоХранилища(ОтборОбработка.ОткрытьМодально());
если помогло нажмите: Спасибо!

Плевел Тратилин

LexaK, Есть.
Эта обработка другие доки заполняет.
И этот док тоже заполняет, если его принудительно пихаю в эту процедуру.

LexaK

а еще в документе Установка цены, своеобразный механизм отображения.
порядок работы следующий
программно создаете, заполняете и ЗАПИСЫВАЕТЕ документ!
и только затем открываете его форму!!! (именно уже по ссылке)
если помогло нажмите: Спасибо!

Плевел Тратилин

LexaK, Да я создаю открываю документ, хоть проведенный хоть нет, и оттуда вызываю. И в нем через механизм дополнительных обработок вызываю вот мою обработку. И бесполезно.

LexaK

Цитата: Плевел Тратилин от 26 апр 2023, 14:06LexaK, Да я создаю открываю документ, хоть проведенный хоть нет, и оттуда вызываю. И в нем через механизм дополнительных обработок вызываю вот мою обработку. И бесполезно.
так вы попробуйте сделать то, что вам посоветовали!
если помогло нажмите: Спасибо!

Плевел Тратилин

LexaK, Да может как посоветовали оно и будет работать. Мне надо суть понять, почему не работают штатные средства и механизмы именно с этим документом, и именно при таком вызове.
Повотрюсь, когда я программно запихиваю сюда Объект документа, всё отрабатывает и заполняет. Костыль я знаю куда и как впихнуть. Хочется понять глубину )))

LexaK

Цитата: Плевел Тратилин от 26 апр 2023, 14:16Мне надо суть понять, почему не работают штатные средства и механизмы именно с этим документом,
то что вы написали не является "штатными средствами"
это какая-то отсебятина очень похожая на гкод.

да и переоткрыть форму документа, какие проблемы? пользователь этого даже не заметит,
была пустая форма, ОП и она уже заполненная!
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск