Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 фев 2024, 02:34

1С 8.3. Как в ОбработкаВыбора узнать на какую кнопку мы нажали?

Автор nasvyaze, 14 дек 2023, 16:46

0 Пользователей и 1 гость просматривают эту тему.

nasvyaze

Код:
Процедура ВыполнитьДействиеНачалоВыбора(Элемент, СтандартнаяОбработка) Экспорт

ФормаВыбора = Справочники.Номенклатура.ПолучитьФормуВыбора( , ЭтаФорма);
ФормаВыбора.Открыть();

КонецПроцедуры // ВыполнитьДействиеНачалоВыбора


Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
ЭлементыФормы.Цех2.Значение = ЗначениеВыбора; //Здесь нужно вместо Цех2 подставить название кнопки, куда мы нажали чтобы выбрать элемент
КонецПроцедуры


Как это правильно сделать?

antoneus

А ВыполнитьДействиеНачалоВыбора откуда вызывается? По-моему, никак не с кнопки.

nasvyaze

antoneus,
Цитата: antoneus от 14 дек 2023, 16:58А ВыполнитьДействиеНачалоВыбора откуда вызывается? По-моему, никак не с кнопки.
Из поля ввода вызывается. Задача такая: в программно созданное поле ввода нажимаем на кнопку выбора (значок "..." который). Открывается справочник, где мы выбираем нужную номенклатуру.
Значение выбранной номенклатуры подставляется в поле ввода: ЭлементыФормы.НазваниеПрограммноСозданногоПоляВвода.Значение = ЗначениеВыбора;

antoneus

А кнопка "..." штатно не отрабатывает что ли? К чему этот весь огород городить?

nasvyaze

antoneus, отрабатывает. Но если программно создать еще одну кнопку с тем же ссылочным типом, то значение подставляется на все формы ввода. А нужно чтобы только подставился там, откуда мы открываем ссылочный тип.

antoneus

Вы случайно не создаете два элемента формы, привязанных к одному реквизиту?

LexaK

nasvyaze, а пробовали так? указывать владельца не форму а элемент

Процедура ВыполнитьДействиеНачалоВыбора(Элемент, СтандартнаяОбработка) Экспорт

СтандартнаяОбработка = ложь;
ФормаВыбора = Справочники.Номенклатура.ПолучитьФормуВыбора( , Элемент); //элемент
ФормаВыбора.Открыть();

КонецПроцедуры // ВыполнитьДействиеНачалоВыбора   
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск