Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 апр 2024, 10:13

Проблема с отображением картинок на веб-клиенте.

Автор nikam0811, 09 окт 2018, 17:21

0 Пользователей и 1 гость просматривают эту тему.

nikam0811

Доброго времени суток,

Имеется управляемая форма номенклатуры в самописной УТ 10.3. На форме есть список номенклатуры, слева от списка имеется поле картинки в которое выводится основное изображение активной номенклатуры. На тонком клиенте все работает без вопросов, но в веб-клиенте начинаются неполадки. При нажатии ПКМ на картинке (картинка отображается в поле) и выборе стандартных функций из выпадающего окна ("Просмотреть картинку", "Сохранить_как") открывается пустое окно, без картинки, либо же выдает ошибку "Неправильный путь к файлу 'e1cib/convertPicture?sysver=8.3.10.2561&interfaceVar=16&scale=100'"
На тонком клиенте эти функции работают нормально.

Код:

&НаКлиенте
Процедура ПоказатьКартинку() Экспорт
   
   ТекЗначение = Элементы.Список.ТекущаяСтрока;
   Если ТекЗначение <> Неопределено Тогда
      СтруктураДанныхКартинки = ПолучитьДанныеКартинки(ТекЗначение);
      Если СтруктураДанныхКартинки.Свойство("НавигационнаяСсылка") = Истина Тогда
         ФотоНоменклатуры = СтруктураДанныхКартинки.НавигационнаяСсылка;
      Иначе
         ФотоНоменклатуры = "";
      КонецЕсли;
      Элементы.ФотоНоменклатуры.Обновить();   


   КонецЕсли;   
   
КонецПроцедуры   

&НаСервере
Функция ПолучитьДанныеКартинки(СсылкаНаНоменклатуру)
   
   УстановитьПривилегированныйРежим(Истина);
   
   ДанныеКартинки = Новый Структура;
   
   Если не СсылкаНаНоменклатуру.ЭтоГруппа Тогда
      ДанныеКартинки.Вставить("НавигационнаяСсылка", ПоместитьВоВременноеХранилище(СсылкаНаНоменклатуру.ОсновноеИзображение.Хранилище.Получить(),
                                    УникальныйИдентификатор));
                                    
   КонецЕсли;
   Возврат ДанныеКартинки;
   
   КонецФункции

Поиск родных

Цитата: nikam0811 от 09 окт 2018, 17:21
Доброго времени суток,

Имеется управляемая форма номенклатуры в самописной УТ 10.3. На форме есть список номенклатуры, слева от списка имеется поле картинки в которое выводится основное изображение активной номенклатуры. На тонком клиенте все работает без вопросов, но в веб-клиенте начинаются неполадки. При нажатии ПКМ на картинке (картинка отображается в поле) и выборе стандартных функций из выпадающего окна ("Просмотреть картинку", "Сохранить_как") открывается пустое окно, без картинки, либо же выдает ошибку "Неправильный путь к файлу 'e1cib/convertPicture?sysver=8.3.10.2561&interfaceVar=16&scale=100'"
На тонком клиенте эти функции работают нормально
Что такое тонкий клиент на УТ 10.3????
Режиме совместимости с версией 8.2.13 выставлен?
Версия УТ 10.3 какая?

nikam0811

Цитата: Геннадий ОбьГЭС от 10 окт 2018, 07:23Что такое тонкий клиент на УТ 10.3????
Режиме совместимости с версией 8.2.13 выставлен?
Версия УТ 10.3 какая?

Версия 10.3.3.3
Режим совместимости выставлен на 8.2.16
В тонком и веб-клиенте запускаю одну из подсистем, вся УТ не переписывалась под управляемые формы.

Похожие темы (5)

Рейтинг@Mail.ru

Поиск