Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 апр 2024, 11:56

Ошибка в запросе.

Автор Кот_Леопольд, 24 сен 2018, 20:49

0 Пользователей и 1 гость просматривают эту тему.

Кот_Леопольд

Помогите с запросом разобраться. Имеется регистр сведений  ЦенаИзделияЗаКвСм , есть документ  УстановкаЦеныИзделияЗаКвСм и есть документ ЗаказПокупателя. Задача в документе ЗаказПокупателя при изменении ВидаПокрытия устанавливалась ЦенаЗаКвСм. Состав регистра Измерение(ВидПокрытия) Ресурс(ЦенаЗаКвСм). Регистратором отмечен документ УстановкаЦеныИзделияЗаКвСм. На форме документа ЗаказПокупателя в реквизите ВидПокрытия создаю событие при изменении (НаСервере)там создаю запрос:
&НаСервере
Функция ПродукцияВидПокрытияПриИзмененииНаСервере(ВидПокрытия, Дата)
//{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЦенаИзделияЗаКвСмСрезПоследних.ЦенаЗаКвСм КАК ЦенаЗаКвСм
|ИЗ
| РегистрСведений.ЦенаИзделияЗаКвСм.СрезПоследних(&Дата, ВидПокрытия = &ВидПокрытия) КАК ЦенаИзделияЗаКвСмСрезПоследних";

Запрос.УстановитьПараметр("Дата", Дата);
Запрос.УстановитьПараметр("ВидПокрытия", ВидПокрытия);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Если ВыборкаДетальныеЗаписи.Следующий() Тогда
Возврат ВыборкаДетальныеЗаписи.Владелец() Иначе
Возврат 0;
КонецЕсли;

//}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

КонецФункции

&НаКлиенте
Процедура ПродукцияВидПокрытияПриИзменении(Элемент)
ТекСтрока = Элементы.Продукция.ТекущиеДанные;
ТекСтрока.ЦенаЗаКвСм = ПродукцияВидПокрытияПриИзмененииНаСервере(ТекСтрока.ВидПокрытия, Объект.Дата);
КонецПроцедуры


При заполнении документа, при изменении ВидаПокрытия выдает ошибку:
{Документ.ЗаказКлиента.Форма.ФормаДокумента.Форма(119)}: Ошибка при вызове метода контекста (ПродукцияВидПокрытияПриИзмененииНаСервере)
   ТекСтрока.ЦенаЗаКвСм = ПродукцияВидПокрытияПриИзмененииНаСервере(ТекСтрока.ВидПокрытия, Объект.Дата);
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'ret':
   форма: Элемент
   имя: {http://v8.1c.ru/8.2/managed-application/modules}ret
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'РезультатЗапроса'


P.S: Отнесись с пониманием, я только учусь!!!
Конфигурацию пишу сам, платформа 8.3.

АлександрВладимирович

Наверно вместо "Возврат ВыборкаДетальныеЗаписи.Владелец()" надо "Возврат ВыборкаДетальныеЗаписи.ЦенаЗаКвСм".

Кот_Леопольд

Цитата: АлександрВладимирович от 24 сен 2018, 23:04
Наверно вместо "Возврат ВыборкаДетальныеЗаписи.Владелец()" надо "Возврат ВыборкаДетальныеЗаписи.ЦенаЗаКвСм".
Спасибо. Все работает!!!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск