Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
15 июл 2024, 05:03

Поле объекта не обнаружено

Автор Q37, 08 авг 2018, 16:50

0 Пользователей и 1 гость просматривают эту тему.

Q37

Всем здравствуйте! Примерная задача: из текстового файла нужно получить данные и создать документ с реквизитами из файла.
&НаКлиенте
Процедура ЗагрузитьОбъект(Команда)
    ВыбранныйДокумент = Объект.Документ;
    загрузитьОбъектПриСозданииНаСервер();
    ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Документ создан");
КонецПроцедуры

&НаСервере           
Функция загрузитьОбъектПриСозданииНаСервер()
    НовыйДок = Документы.АвансовыйОтчет.СоздатьДокумент();
    НовыйДок.Дата = ТекущаяДата();
         ПутьКФайлу = Объект.Файл + "\out.txt";
    ТекстовыйФайл = Новый ТекстовыйДокумент;

    ТекстовыйФайл.Прочитать(
        ПутьКФайлу,
        КодировкаТекста.UTF8,
        Символы.ВК + Символы.ПС
    );
    Индекс =2;
    Пока Индекс < ТекстовыйФайл.КоличествоСтрок() Цикл
        НазваниеРеквизита =ТекстовыйФайл.ПолучитьСтроку(Индекс);
        ЗначениеРеквизита = ТекстовыйФайл.ПолучитьСтроку(Индекс+1);
        НовыйДок.НазваниеРеквизита = ЗначениеРеквизита;
        Индекс = Индекс + 2 ;
    КонецЦикла;
    НовыйДок.Записать();
    Возврат НовыйДок;
КонецФункции


Выдаёт "Поле объекта не обнаружено(Название реквизита)"

В чём ошибка? Подскажите пожалуйста

Q37

НазваниеРеквизита нужно поместить в квадратные скобки.
НовыйДок[НазваниеРеквизита]
Тема закрыта.

wise

(1) сам с собой поговорил... :-)
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Теги:  

Похожие темы (5)

Рейтинг@Mail.ru

Поиск