Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 апр 2024, 00:16

Гиперссылка в управляемой форме

Автор xxxSuperBoyxxx, 24 июл 2018, 16:16

0 Пользователей и 1 гость просматривают эту тему.

xxxSuperBoyxxx

1С 8.3 Хочется видеть пользовательский обработчик в табличном поле формы (по окончанию: список файлов, приложенных к документу, щелкнул по любому, он тут же открылся)
Что было сделано: в управляемой форме списка документа добавлено "поле надписи" в котором содержится имя файла. В свойствах поля установлена галка "Гиперссылка", Событие Нажатие установлено:
&НаКлиенте
Процедура Поле1Нажатие(Элемент, СтандартнаяОбработка)
Сообщить("Текст");
КонецПроцедуры


Но поле всё равно остаётся некликабельным.
Галка "Гиперссылка ячейки" сделала подчеркнутым поле, но обработчик всё равно не запускается. Режимы совместимости дело не исправили. Также как и Событие ОбработкаНавигационнойСсылки.
Я что-то делаю не так или задумка невозможна? Только через контекстное меню или кнопку сверху?

Sy4a

Динамический список это дело такое) была бы таблица значений всё бы отработало, попробуй повесить в событие "ПриАктивизацииПоля" в свойствах у Списка, ешё там есть при активизации ячейки. Также можешь попробовать там же где делал поставить у поля только просмотр мб поможет.
Добавлено: 24 июл 2018, 16:45


Ещё можно повесить в событие Выбор (которое вызывается при двойном клике), там в параметрах есть "поле" (вроде как это колонка) и если это ваша колонка то станадртанаяобработка=ложь и твой код.

xxxSuperBoyxxx

Немного ещё покопавшись, сделал так:
1. В свойствах поля поставил "ГиперссылкаЯчейки". Методом тыка определил, что свойство вызывает событие "Выбор" при однократном нажатии на текст (по сути эмулирует двойное нажатие на ячейку). Стандартной обработкой которого является открытие формы элемента.
2. В событии "Выбор" таблицы поставил код
Процедура СписокВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
Если Поле.ГиперссылкаЯчейки тогда
  СтандартнаяОбработка = Ложь;
  Сообщить("привет");
КонецЕсли
КонецПроцедуры


Свойство поля "Гиперссылка" и событие "Нажатие" убрал, т.к. на табличные списки они никак не влияет.
Отличие от первоначальной задумки в том, что при двойном нажатии просто на ячейку с именем файла тоже будет открываться файл, а не форма элемента, но для меня это неважно.

P.S. Спасибо Sy4a, за подсказку

Похожие темы (5)

Рейтинг@Mail.ru

Поиск