Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 фев 2024, 03:21

помогите сделать выборку

Автор 6aToH, 31 мар 2011, 12:18

0 Пользователей и 1 гость просматривают эту тему.

6aToH

Есть ТЗ с кучей колонок и строк.
Одна из колонок код, он состоит из 11 Символов Например(GHJ2JKDKKDK).
есть список таких же кодов только урезанных(от кода взяли 5 или 4 или 6 первых символов(длина может быть разной))
так вот нужно перебрать ТЗ на условие принадлежности соответствующей длина кода СпискуЗначений.

Что можете предложить?

З.Ы. понятно объяснил???

6aToH

уточню вопрос: через запрос можно?
вообще запросом можно обратиться к ТЗ?

6aToH

про запрос уже выяснил опытным путем!
говорит:Неверно заданный путь

prog1c7.7

т.е. тебе надо выбрать значения из ТЗ, с условием равности значению колонки Код какой
либо исходной , или как?

6aToH

Цитата: prog1c7.7 от 31 мар 2011, 13:25
т.е. тебе надо выбрать значения из ТЗ, с условием равности значению колонки Код какой
либо исходной , или как?
вот пример:
ТЗ-1
Строка1 Код =ABCD2EFGHIJ
Строка2 Код =BCD2EFGHIJA
Строка3 Код =CD2EFGHIJAB
Строка4 Код =D2EFGHIJABС

ТЗ-2
Строка1 Код=ABCD2
Строка2 Код=BCD2EF
Строка3 Код=CD2EFGH

Строки с 1 по 3 из ТЗ-1 должны попасть в отбор

Flamepayne

Вам нужно, чтобы короткие коды из тз-1  заменялись полным кодом из тз-2. Правильно понял?
За очками нужен глаз, да глаз.

Flamepayne

Вообщем, так:
ТЗ-3=СоздатьОбъект("ТаблицаЗначений");
ТЗ-З.НоваяКолонка("ВыборкаКодов");
для i=1 по ТЗ-2.количествоСтрок() цикл
   КорКод=ТЗ-2.ПолучитьЗначение(i,"Код")
   для j=1 по ТЗ-1.Количество строк() цикл
      ДлинКод=ТЗ-1.ПолучитьЗначение(j,"Код")
      Если  СтрЧислоВхождений(ДлинКод,КорКод)=1 тогда
         ТЗ-3.НоваяСтрока();
         ТЗ-3.ВыборкаКодов=ДлинКод;
      КонецЕсли;
    КонецЦикла;
КонецЦикла; 

    Здесь все необходимые кода попадают в ТЗ-3. Вы сделайте сами куда нужно Вам.   
За очками нужен глаз, да глаз.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск