Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
13 апр 2024, 03:28

Вопрос по Задолженности Дт, Кт

Автор Элен62, 01 мар 2011, 14:43

0 Пользователей и 1 гость просматривают эту тему.

Элен62

Подскажите, я формирую отчет, который должен выводить Задолженность -2 колонки Дт и Кт.  Известен Контрагент, номер Договора, Сумма Договора, Фактическая сумма по актам, Оплата ( по 62 счету берется), и Остаток по договору и Итог уже есть. А как задолженность вытащить. Из Каких регистров брать? 90 счет. Хозрасчетный/Обороты.....? что еще вытащить? Вот запрос из моего кода. Подскажите пожалуйста, а то с бухгалтерией проблемки)).

ВЫБРАТЬ
                  |   ХозрасчетныйОбороты.Организация,
                  |   ХозрасчетныйОбороты.Субконто1 КАК Контрагент,
                  |   ХозрасчетныйОбороты.Субконто2.Родитель КАК ГруппаДоговора,
                  |   ХозрасчетныйОбороты.Субконто2 КАК Договор,
                  |   ХозрасчетныйОбороты.Субконто2.Комментарий КАК СуммаДоговора,
                  |   ХозрасчетныйОбороты.СуммаОборотКт КАК СуммаАванса
                  |ИЗ
                  |   РегистрБухгалтерии.Хозрасчетный.Обороты(&НачалоПериода, &КонецПериода, , Счет В ИЕРАРХИИ (&Счет1), , , , ) КАК ХозрасчетныйОбороты";
   

progmikon

В самом простом случае, если остаток по 62.01 это ваша дебиторка, если остаток по 62.02 - это аванс вам от покупателя, т.е. кредиторка.

Элен62

а вот так программно правильно будет?

Процедура СформироватьЗапрос(ТаблицаЗапроса)
ТекстУсловия3 = "";
Запрос = Новый Запрос;
Запрос.УстановитьПараметр("Счет1", ПланыСчетов.Хозрасчетный.НайтиПоКоду("62"));
   Запрос.УстановитьПараметр("Счет2", ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.01"));
Запрос.УстановитьПараметр("Организация", Организация);
Запрос.УстановитьПараметр("Контрагент", Контрагент);
Если ЗначениеЗаполнено(ДатаНач) Тогда
Граница = Новый Граница(НачалоДня(ДатаНач), ВидГраницы.Включая);
Запрос.УстановитьПараметр("НачалоПериода", Граница.Значение);
Иначе
Запрос.УстановитьПараметр("НачалоПериода", Дата('00010101000000'));
КонецЕсли;
Если ЗначениеЗаполнено(ДатаКон) Тогда
Граница = Новый Граница(КонецДня(ДатаКон), ВидГраницы.Включая);
Запрос.УстановитьПараметр("КонецПериода", Граница.Значение);
Иначе
Граница = Новый Граница(КонецДня(ТекущаяДата()), ВидГраницы.Включая);
Запрос.УстановитьПараметр("КонецПериода", Граница.Значение);
КонецЕсли;
Запрос.Текст = "ВЫБРАТЬ
              | ХозрасчетныйОбороты.СуммаОборотДт,
  | ХозрасчетныйОбороты.СуммаОборотКт,
                  | ХозрасчетныйОбороты.Организация,
              | ХозрасчетныйОбороты.Субконто1 КАК Контрагент,
              | ХозрасчетныйОбороты.Субконто2.Родитель КАК ГруппаДоговора,
              | ХозрасчетныйОбороты.Субконто2 КАК Договор,
              | ХозрасчетныйОбороты.Субконто2.Комментарий КАК СуммаДоговора
              |ИЗ
              | РегистрБухгалтерии.Хозрасчетный.Обороты(&НачалоПериода, &КонецПериода, , Счет В ИЕРАРХИИ (&Счет1), , , , ) КАК ХозрасчетныйОбороты";
  |РегистрБухгалтерии.Хозрасчетный.Обороты(&НачалоПериода, &КонецПериода, , Счет В ИЕРАРХИИ (&Счет2), , , , ) КАК ХозрасчетныйОбороты";
Если Организация <> Справочники.Организации.ПустаяСсылка() Тогда
ТекстУсловия1 = "
|   ГДЕ
              | ХозрасчетныйОбороты.Организация = &Организация";
Иначе
ТекстУсловия1 = "";
КонецЕсли;
Если Контрагент = Справочники.Контрагенты.ПустаяСсылка() Тогда
ТекстУсловия2 = "";
Иначе
Если ТекстУсловия1 <> "" Тогда
ТекстУсловия2 = "
| И ХозрасчетныйОбороты.Субконто1 = &Контрагент";
Иначе
ТекстУсловия2 = "
|   ГДЕ
              | ХозрасчетныйОбороты.Субконто1 = &Контрагент";
КонецЕсли;
КонецЕсли;
Запрос.Текст = Запрос.Текст + ТекстУсловия1 + ТекстУсловия2 + ТекстУсловия3;
ТаблицаЗапроса = Запрос.Выполнить().Выгрузить();
КонецПроцедуры

Вот не понимаю я тогда, про какой 90й счет мне клиенты говорят тогда?

progmikon

на 90 счете отражаются ваши продажи.

progmikon

А зачем вот эта конструкция

|РегистрБухгалтерии.Хозрасчетный.Обороты(&НачалоПериода, &КонецПериода, , Счет В ИЕРАРХИИ (&Счет1), , , , ) КАК ХозрасчетныйОбороты";
|РегистрБухгалтерии.Хозрасчетный.Обороты(&НачалоПериода, &КонецПериода, , Счет В ИЕРАРХИИ (&Счет2), , , , ) КАК ХозрасчетныйОбороты";

Элен62

Это для дальнейшей подвязки кода. Могу скинуть отчетик на почту, здесь к сожалению папка загрузки не работает((.

progmikon

К вечеру должны вложения заработать.

Элен62

Было бы здорово, а то так уже с недельку отправить не могу). Тогда выложу вечером. Пока почитаю теорию.

Элен62

прикладываю ведомость (внешний отчет)

Элен62

В колонках Дт и Кредит не считается, т.к. не знаю к чему обращаться конкретно. Хозрасчетный/... Заранее спасибо)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск