Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 мая 2024, 12:33

Помогите решить проблему

Автор Jogurt12, 18 дек 2013, 16:14

0 Пользователей и 1 гость просматривают эту тему.

Jogurt12

После отладки конфигуратор выдает следующую ошибку :{ОбщийМодуль.ОбщепитДокументы.Модуль(722)}: Поле объекта не обнаружено (ОбщепитТаблицаСуммСписания)
   Если ЗначениеЗаполнено(ДанныеСтроки.Номенклатура) и выделяет следующую область :
Функция ОбщепитТоварыПриВыводеСтроки(ЭтаФорма, ТабличноеПоле, Элемент, ОформлениеСтроки, ДанныеСтроки) Экспорт
Если ТабличноеПоле.Колонки.Найти("СуммаСписания") = Неопределено
ИЛИ НЕ ТабличноеПоле.Колонки.СуммаСписания.Видимость Тогда
Возврат 0;
КонецЕсли;

СуммаСписания = 0;
Если ЗначениеЗаполнено(ДанныеСтроки.Номенклатура)
И ЭтаФорма.ЭтотОбъект.Проведен
И НЕ ЭтаФорма.ОбщепитТаблицаСуммСписания.Количество() = 0 Тогда

СтрокаСуммСписания =  ЭтаФорма.ОбщепитТаблицаСуммСписания.Найти(ДанныеСтроки.Номенклатура ,"Номенклатура");
Если СтрокаСуммСписания <> Неопределено Тогда
СуммаСписания = СтрокаСуммСписания.Сумма;
КонецЕсли;

КонецЕсли;

ОформлениеСтроки.Ячейки.СуммаСписания.Выравнивание=ГоризонтальноеПоложение.Право;
Если СуммаСписания < 0 Тогда
ОформлениеСтроки.Ячейки.СуммаСписания.ЦветТекста = WebЦвета.Красный;
КонецЕсли;
ОформлениеСтроки.Ячейки.СуммаСписания.УстановитьТекст(Формат(СуммаСписания,"ЧЦ=15; ЧДЦ=2; ЧРГ=' '; ЧН=0.00"));
КонецФункции



MuI_I_Ika

Вы привели функцию из какой-то формы, а у вас ошибка в общем модуле:

ОбщийМодуль.ОбщепитДокументы.Модуль

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск