Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
19 апр 2024, 11:21

Заполнить табличную часть документа

Автор WolfBlack, 18 июл 2011, 11:58

0 Пользователей и 1 гость просматривают эту тему.

WolfBlack

Люди добрые, подскажите пожалуйста как заполнить табличную часть документа из справочника Сотрудники

chuevsf

Сформулируйте вопрос точнее. Сейчас не вопрос,а каша.

WolfBlack

Цитата: chuevsf от 18 июл 2011, 12:06
Сформулируйте вопрос точнее. Сейчас не вопрос,а каша.
Мне нужно в документ "Табель1" с табличной частью "ТабличнаяЧасть1" в колонку "Сотрудник" по нажатию кнопки "Заполнить" заполнить ФИО из справочника "Сотрудники" с иерархической формой списка, которая содержит в себе Уволенных и Основных, нужно заполнить из Основных

Шурыгин Иван Сергеевич

напишите запрос, в нем условие.
загрузите в табличную часть таким кодом:

ТабличнаяЧасть1.Загрузить(Запрос.Выполнить.Выгрузить());
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================

WolfBlack

Цитата: Шурыгин Иван Сергеевич от 18 июл 2011, 12:20
напишите запрос, в нем условие.
загрузите в табличную часть таким кодом:

ТабличнаяЧасть1.Загрузить(Запрос.Выполнить.Выгрузить());

Это как-то сложновато... Нельзя ли просто как-то циклом пробежаться по справочнику и так же циклом заполнить табличную часть документа?

WolfBlack

Например как-то так:
Таб=ЭлементыФормы.ТабличноеПоле1;
   Таб.очистить();
   Если Таб.КоличествоСтрок() =0 тогда
      Сотр= СоздатьОбъект(Справочники.Сотрудники);
      Сотр.ВыбратьЭлементы();
      Пока Сотр.ПолучитьЭлемены()=1 Цикл
         Таб.НоваяСтрока();
      КонецЦикла;
   КонецЕсли;   
Только эта байда не работает.. :)

has

Цитата: WolfBlack от 18 июл 2011, 12:41
Это как-то сложновато... Нельзя ли просто как-то циклом пробежаться по справочнику и так же циклом заполнить табличную часть документа?
Почему сложновато? В чем смысл цикла в данном случае?

WolfBlack

Цитата: has от 18 июл 2011, 13:00
Цитата: WolfBlack от 18 июл 2011, 12:41
Это как-то сложновато... Нельзя ли просто как-то циклом пробежаться по справочнику и так же циклом заполнить табличную часть документа?
Почему сложновато? В чем смысл цикла в данном случае?
Потому что я только начал изучать 1с и до запросов ещё не добрался... только до циклов... потому и хочу проверить как это работает...

Шурыгин Иван Сергеевич

Цитата: WolfBlack от 18 июл 2011, 12:43
Например как-то так:
Таб=ЭлементыФормы.ТабличноеПоле1;
   Таб.очистить();
   Если Таб.КоличествоСтрок() =0 тогда
      Сотр= СоздатьОбъект(Справочники.Сотрудники);
      Сотр.ВыбратьЭлементы();
      Пока Сотр.ПолучитьЭлемены()=1 Цикл
         Таб.НоваяСтрока();
      КонецЦикла;
   КонецЕсли;   
Только эта байда не работает.. :)

это код 7ки!
в 8. такая конструкция

Выборка = Справочники.Сотрудники.Выбрать();

Пока Выборка.Следующий() Цикл
//заполняйте строку ТЧ
КонецЦикла;
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================

WolfBlack

Цитата: Шурыгин Иван Сергеевич от 18 июл 2011, 13:07
это код 7ки!
в 8. такая конструкция

Выборка = Справочники.Сотрудники.Выбрать();

Пока Выборка.Следующий() Цикл
//заполняйте строку ТЧ
КонецЦикла;

Пиушу так:

Выборка=Справочники.Сотрудники.Выбрать();
СтрокаТабличнойЧасти=ЭлементыФормы.ТабличноеПоле1.ТекущиеДанные;
Пока Выборка.Следующий()цикл
СтрокаТабличнойЧасти.Сотрудник=(Что сюда написать?);
КонецЦикла;

Или я вообще не правильно мыслю?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск