Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 июл 2024, 19:29

Пауза в цикле

Автор Nosferatu112, 10 июл 2024, 15:36

0 Пользователей и 1 гость просматривают эту тему.

Nosferatu112

Всем привет, есть ли возможность сделать в цикле паузу? Я качаю файлы с сервера к которому можно сделать 10 обращений в сек есть ли в 1с возможность при каждой новой итерации цикла ставить задержку в 1 сек?

Максим75

Nosferatu112, да, есть.

типа такого:
Процедура Ping_01(Секунд);
   
   если Секунд=0 Тогда
      возврат;
   КонецЕсли;
   
   КомандаWindows = "ping -n 1 -w "+Формат(1000 * Секунд, "ЧДЦ=0; ЧГ=") + " 127.255.255.255";
   WshShell = Новый COMОбъект("WScript.Shell");
   WshShell.Run(КомандаWindows, 0, -1);
   
КонецПроцедуры

LexaK

еще можно использовать
ПодключитьОбработчикОжидания(,,,);
если помогло нажмите: Спасибо!

antoneus


Начало = ТекущаяДата();
Пока ТекущаяДата() - Начало <= 1 Цикл
КонецЦикла;

LexaK

antoneus, это самая плохая конструкция паузы! просто тупо грузит процессор!
если помогло нажмите: Спасибо!

antoneus

А что делать на сервере при отсутствии формы?

LexaK

antoneus, Ping-овать (для виндов)
Sleep - для Линукса
или с клиента порциями запускать серверный код через обработчик ожидания
(и конечно в самом крайнем случае остается цикл по времени)
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск