Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 июл 2024, 19:54

Обработка

Автор Дмитрий11, 10 июл 2024, 13:04

0 Пользователей и 1 гость просматривают эту тему.

Дмитрий11

Всем привет.Хочу попробовать каким то образом вытащить часть наименования и заполнить им реквизит.
Т.Е. имеем наименование в начале идут цифры,далее текст, вот эти цифры хочу вытащить в реквизит номер по каталогу и пробежаться по всей номенклатуре.Не мойму каким образом отделить от текста именно до пробела, потому что в перемешку с цифрами могут быть буквы

Максим75

Дмитрий11,
Функция ТолькоЧислаВСтроке(Строка)
   
   СтрокаЧисел = "";
   Для Индекс = 1 По СтрДлина(Строка) Цикл
      Символ = Сред(Строка, Индекс, 1); // Перебираем все сиволы из нашей строки
      Если КодСимвола(Символ) >= 48 И КодСимвола(Символ) <= 57 Тогда // Код нуля - 48, код 9-ки - 57
         СтрокаЧисел = СтрокаЧисел + Символ;
         
      КонецЕсли;
   КонецЦикла;
   
   Возврат СтрокаЧисел;
   
КонецФункции

вернет только числа в переданной строке

bsn-chita

Если наименование представляет из себя всегда какое либо число плюс пробел и далее любой текст, то можно с помощью СтрРазделить по разделителю пробел получить массив и в первом его элементе будет наше "число".

antoneus

СимволыДоПробела = Лев(Наименование, СтрНайти(Наименование, " ") - 1)
а, ну или по пробелу разделить, да)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск