Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 июл 2024, 20:29

Переменная не определена (Документы)

Автор S#4, 22 июн 2024, 13:49

0 Пользователей и 1 гость просматривают эту тему.

S#4

Имеется данный код:
Процедура Команда1(Команда)
    выборка = Документы.СоставБригады.Выбрать();
    Пока Выборка.Следующий() Цикл
    Сообщить(СтрШаблон("%1", выборка.Водитель));   
    КонецЦикла;   
    //Сообщить(выборка.Водитель);
КонецПроцедуры
Но пишет что: {ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(4,12)}: Переменная не определена (Документы)
    выборка = <<?>>Документы.СоставБригады.Выбрать(); (Проверка: Тонкий клиент)
В чем проблема?
P.s. пробовал переключать на толстый клиент и все равно выдает данную ошибку.

antoneus

Ну на толстом должно было взлететь. А лучше делать это все-таки на сервере, для универсальности, тыкскыть.

Optiman

Цитата: S#4 от 22 июн 2024, 13:49выборка = <<?>>Документы.СоставБригады.Выбрать(); (Проверка: Тонкий клиент)
На клиенте Документы не доступны. Надо на сервер переходить.

LexaK

S#4, именно так, парами почти все команды обрабатываются, пример
&НаКлиенте
Процедура Команда1(Команда)
    Команда1Сервер();
КонецПроцедуры

&НаСервере
Процедура Команда1Сервер()
    выборка = Документы.СоставБригады.Выбрать();
    Пока Выборка.Следующий() Цикл
    Сообщить(СтрШаблон("%1", выборка.Водитель));   
    КонецЦикла;   
    //Сообщить(выборка.Водитель);
КонецПроцедуры
если помогло нажмите: Спасибо!

Похожие темы (1)

Рейтинг@Mail.ru

Поиск