Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 июл 2024, 21:12

Получить имя табличной части

Автор denzo, 19 июн 2024, 09:00

0 Пользователей и 1 гость просматривают эту тему.

denzo

Добрый день! Передаю ТЧ через параметры в другую форму и хочу в другой форме получить имя этой ТЧ. Не могу понять как это сделать.
//Форма документа
&НаКлиенте
Процедура Приложение_Печать(Команда)
ПараметрыФормы = Новый Структура;
ПараметрыФормы.Вставить("ТЧ",Объект.ИмяТЧ);
ОткрытьФорму("Документ.Отчет.Форма.ФормаПечати",ПараметрыФормы);
КонецПроцедуры

//Другая форма
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
ТЧФормыДокумента = Параметры.ТЧ;
Сообщить(ТЧФормыДокумента.Имя);
КонецПроцедуры
Сообственно при таком раскладе получаю ошибку.

Максим75

denzo, Сообщить(ТЧФормыДокумента); без Имя

LexaK

denzo, (а этот код вообще работает?)
тогда попробуйте так
//Форма документа
&НаКлиенте
Процедура Приложение_Печать(Команда)
ПараметрыФормы = Новый Структура;
ПараметрыФормы.Вставить("ТЧ",Объект.ИмяТЧ);
ПараметрыФормы.Вставить("ИмяТЧ","Объект.ИмяТЧ");
ОткрытьФорму("Документ.Отчет.Форма.ФормаПечати",ПараметрыФормы);
КонецПроцедуры

//Другая форма
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    ТЧФормыДокумента = Параметры.ТЧ;
Сообщить(Параметры.ИмяТЧ);
КонецПроцедуры
если помогло нажмите: Спасибо!

denzo

LexaK, Спасибо натолкнули в правильную сторону. Передал отдельным параметром имя элементы формы ТЧ
ПараметрыФормы.Вставить("ТЧИмя",Элементы.ФильмыСериалы.Имя);

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск