Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 июн 2024, 02:54

Прошу, помогите

Автор Рад, 10 июн 2024, 17:14

0 Пользователей и 1 гость просматривают эту тему.

Рад

Ребят подскажите где поправить код?

После добавления .jpg нажать Записать И Закрыть - то при повторном открытии картинка не отображается! Знатоков прошу подсказать в чем дело?

&НаКлиенте
Процедура СсылкаНаКартинкуНажатие(Элемент, СтандартнаяОбработка)
      СтандартнаяОбработка = Ложь;
      Режим = РежимДиалогаВыбораФайла.Открытие;
      ДиалогОткрытия = Новый ДиалогВыбораФайла(Режим);
      ДиалогОткрытия.ПолноеИмяФайла = "";
      Фильтр = "Файл JPG (*.jpg)|*.jpg";
      ДиалогОткрытия.Фильтр = Фильтр;
      ДиалогОткрытия.МножественныйВыбор = Ложь;
      ДиалогОткрытия.Заголовок = "Выберите файл для загрузки";
      ОписаниеОповещения = Новый ОписаниеОповещения ("ПослеЗагрузкиФайла", ЭтаФорма);
      ДиалогОткрытия.Показать (ОписаниеОповещения);
КонецПроцедуры

&НаКлиенте
Процедура ПослеЗагрузкиФайла(ВыбранныйФайл, ДопПараметр) Экспорт
      Если ВыбранныйФайл = Неопределено Тогда
         Возврат;
      КонецЕсли;
      ОписаниеОповещения = Новый ОписаниеОповещения ("ПослеПомещенияФайла", ЭтаФорма);
      НачатьПомещениеФайла (ОписаниеОповещения,, ВыбранныйФайл
  • , Ложь, УникальныйИдентификатор);
КонецПроцедуры

&НаКлиенте
Процедура ПослеПомещенияФайла(Результат, Адрес, ВыбранноеИмяФайла, ДопПараметры) Экспорт
      Если Не Результат Тогда
         Возврат;
      КонецЕсли;
      СсылкаНаКартинку = Адрес;
      Модифицированность = Истина;
КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере (Отказ, ТекущийОбъект, ПараметрыЗаписи)
      Если ЭтоАдресВременногоХранилища (СсылкаНаКартинку) Тогда
         ФайлКартинки = ПолучитьИзВременногоХранилища (СсылкаНаКартинку);
         ТекущийОбъект.Изображение = Новый ХранилищеЗначения (ФайлКартинки);
         УдалитьИзВременногоХранилища (СсылкаНаКартинку);
         СсылкаНаКартинку = ПолучитьНавигационнуюСсылку (Объект.Ссылка, "");   
      КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере (Отказ, СтандартнаяОбработка)
   СсылкаНаКартинку = ПолучитьНавигационнуюСсылку (Объект.Ссылка, "");   
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск