Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 июн 2024, 02:23

Сделать отбор обязательным

Автор esscargoott, 29 мая 2024, 10:39

0 Пользователей и 1 гость просматривают эту тему.

esscargoott

Здравствуйте! Сделала отчет есть две его формы (диаграмма и таблица) и мне надо чтоб при диаграмме был отбор по курсам (обязательно пользователь должен быть) , а в таблице отбор по пользователям (обязательный). 
Но у меня при снятии галочки отбора отчет формируется непонятно как, надо чтоб только с данными отбора он формировался

Максим75

Процедура УстановитьОтборСКД(ИмяПоля, ВидОтбора, Значение)
    ПолеОтбора         = Новый ПолеКомпоновкиДанных(ИмяПоля);
    ОтборыКомпановщика = КомпоновщикНастроек.Настройки.Отбор.Элементы;
    Для Каждого Стр Из ОтборыКомпановщика Цикл
        Если Стр.ЛевоеЗначение = ПолеОтбора Тогда
            Отбор = Стр;
        КонецЕсли;
    КонецЦикла;
    Если Отбор = Неопределено Тогда
        Отбор               = КомпоновщикНастроек.Настройки.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
        Отбор.ЛевоеЗначение = ПолеОтбора;
    КонецЕсли;
    Если Значение <> Неопределено Тогда
        Отбор.ВидСравнения   = ВидОтбора;
        Отбор.Использование  = Истина;
        Отбор.ПравоеЗначение = Значение;
    Иначе
        Отбор.Использование = Ложь;
    КонецЕсли;
КонецПроцедуры

Процедура ПриОткрытии()
УстановитьОтборСКД("Филиал", ВидСравненияКомпоновкиДанных.НеРавно, Справочники.Филиалы.НайтиПоКоду("000000028"));
КонецПроцедуры

ну вот примерно такой код.
При открытии вызываете установку отбора.
Естественно, замените на свое.

esscargoott

Максим75, , а в настройках нет никаких кнопок? чтоб код не писать...

Afinogen

а пользователь это вообще что за поле? это поле в отчете?

Afinogen

сделайте 2 отбора

1.й - пользователь  Заполнен
2 -й ваш конкретно выбранный пользователь

Тогда если не укажут конкретного пользователя вам отчет выдаст пустой

antoneus

Ну вместо отбора сделайте параметр.

Теги:  

Похожие темы (5)

Рейтинг@Mail.ru

Поиск