Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 июн 2024, 02:25

Обновить ссылку элемента справочника

Автор Дмитрий11, 29 мая 2024, 10:39

0 Пользователей и 1 гость просматривают эту тему.

Дмитрий11

Всем привет! Подскажите, написал обработку, которая массово меняет срок годности у номенклатуры.При запуске обработки сам реквизит СрокГодности меняется, а ссылка остается прежней. Если в элемент справочника провалится и записать, то ссылка меняется.Что нужно дописать в обработке?
&НаСервере
Процедура СменаСрокаГодностиНаСервере()
Сч=0;
Для Каждого Стр из Объект.СписокТМЦ Цикл
Сч=Сч+1;
Если Стр.Флаг=Ложь Тогда
Продолжить;
КонецЕсли;

Попытка

ТекНоменкл=Стр.СерииНоменклатуры.ПолучитьОбъект();
ТекНоменкл.ГоденДо=Объект.СрокГодностиНовый;
ТекНоменкл.ОбменДанными.Загрузка = Истина;
            ТекНоменкл.Записать();



Исключение
Сообщить("Ошибка в изменении ТМЦ в строке"+Сч);

КонецПопытки
КонецЦикла;
Сообщить("Обработка данных завершена");
КонецПроцедуры

&НаКлиенте
Процедура СменаСрокаГодности(Команда)
Если ЗначениеЗаполнено(Объект.СрокГодностиНовый)  Тогда
СменаСрокаГодностиНаСервере();
ОповеститьОбИзменении(Тип("СправочникСсылка.СерииНоменклатуры"));
Иначе
Сообщить("Не выбран новый срок годности в шапке");
КонецЕсли;
КонецПроцедуры

LexaK

Дмитрий11, попробуйте вот это убрать!
ТекНоменкл.ОбменДанными.Загрузка = Истина;
если помогло нажмите: Спасибо!

Дмитрий11

LexaK, Действительно помогло....Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск