Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 июн 2024, 02:35

Автообновление формы списка документов в самописной конфигурации

Автор DKNY, 23 мая 2024, 14:28

0 Пользователей и 1 гость просматривают эту тему.

DKNY

Добрый день всем!
Помогите, пожалуйста, разобраться.
Есть самописная конфигурация 1С 8,3, в ней форма списка документов. Как сделать чтобы документы в ней обновлялись (появлялись/изменялись) автоматически в режиме онлайн? Автообновление не совсем подходит, так как в базе одновременно сидит от 4х до 10и человек и все они должны видеть изменение списка в режиме онлайн.
Пробовала писать в форме документа
&НаКлиенте
Процедура ПослеЗаписи(ПараметрыЗаписи)
    Оповестить("ОбновитьСписок");
КонецПроцедуры

а в форме списка
&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
    Если ИмяСобытия = "ОбновитьСписок" Тогда
        ЭтаФорма.ОбновитьОтображениеДанных();
    КонецЕсли;
КонецПроцедуры

Не работает.

LexaK

DKNY, а почему автообновление не подходит? оно как раз для этого и предназначено
(если все правильно у вас сделано, а не как обычно)

еще можно использовать
ПодключитьОбработчикОжидания(...)
если помогло нажмите: Спасибо!

DKNY

LexaK, потому что документы вводятся с разной периодичностью, могут ничего не вводить минут 15, а могут вводить по несколько в минуту и в то время как один пользователь ввел, второй должен его сразу увидеть, чтобы отработать в своей части. Если ставить автообновление с периодичностью в 1 секунду оно как бы обновляется, да, но эти "часы" постоянные не красиво, да и системе думаю это не очень хорошо, потому что база уже не маленькая (только за сегодня введено уже 220 документов).
Спасибо за наводку, буду пытаться разобраться с подключением Обработчика ожидания (куда, как и когда).

DKNY

LexaK, А почему не работает "ПослеЗаписи и ОбработкаОповещения" (то, что я в описании вопроса написала)?

LexaK

Цитата: DKNY от 23 мая 2024, 15:17А почему не работает "ПослеЗаписи и ОбработкаОповещения"

очень внимательно СП надо читать!  :befhbt:
эти события и методы работают в рамках текущего сеанса
и ни как на сеансы других пользователей не влияют!

только опрос с заданной периодичностью (поставьте 5 секунд, вместо одной)
если помогло нажмите: Спасибо!

DKNY

LexaK,
Цитироватьэти события и методы работают в рамках текущего сеанса
и ни как на сеансы других пользователей не влияют!
Зачем же они тогда нужны, я же вижу, и так без этих событий и методов, что я делаю  :xfbnsdfb:

Цитироватьтолько опрос с заданной периодичностью (поставьте 5 секунд, вместо одной)
Вы про автообновление? не будет это нагружать и/или тормозить 1С?

LexaK

DKNY,
ЦитироватьЗачем же они тогда нужны, я же вижу, и так без этих событий и методов, что я делаю  :xfbnsdfb:
а это не для вас! это для тех форм и списков которые вы назапускали в СВОЕМ сеансе!  они то друг о друге ни чего не знают.
вот с помощью оповещений и узнают,

ЦитироватьВы про автообновление? не будет это нагружать и/или тормозить 1С?
но это уже зависит какой код/запрос вы напишите!
(есть оптимальные запросы, а могут быть и г..запросы)
если помогло нажмите: Спасибо!

DKNY

LexaK,
Цитироватьно это уже зависит какой код/запрос вы напишите!
(есть оптимальные запросы, а могут быть и г..запросы)
дело ясное, что дело темное... Я думала Вы говорите про автообновление с периодичностью в 5 сек и будет все ок

LexaK

DKNY, а вы как свою форму со списком делаете? что является источником данных?
может быть просто запрос
может быть динамический список
динамический список может быть на произвольном запросе

месть , где можно наГкодить - достаточно.
если помогло нажмите: Спасибо!

DKNY

LexaK, простоя форма списка...  :xfbnsdfb:
я пока обойдусь автообновлением)))

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск