Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 июн 2024, 02:17

Https запрос с ошибкой

Автор Nosferatu112, 20 мая 2024, 16:43

0 Пользователей и 1 гость просматривают эту тему.

Nosferatu112

Приветствую, есть у меня обработка которая скачивает файлы с http ресурса и потом отправляет их на другой . Ранее место куда я отправлял файл было http://00.00.000.000 всё отлично работало.
Пока были выходные админ некоректно открепил IP и привязал новый https://00.00.000.000
И теперь ни чего не работает и я не могу понять почему

На этой строке кода
Ответ = Соединение.ОтправитьДляОбработки(Запрос);Выходит ошибка:
{ОбщийМодуль.РаботаСИнтернетКлиентСервер.Модуль(116)}: Ошибка при вызове метода контекста (ОтправитьДляОбработки): Ошибка работы с Интернет:  Не могу установить соединение
Сертификаты есть
Порт 443
Api-key в заголовки передаю
До этого был порт 5000 выходила ошибка SSL соединения
Порт поменял начала вылазить ошибка которую я описал выше
Куда копать, может кто подскажет?


LexaK

Цитата: Nosferatu112 от 20 мая 2024, 16:43Не могу установить соединение
да вроде, понятнее не куда описание ошибки!
с переподключение ИП, сервис то запущен на том, удаленном сервере? к чему вы соединяетесь и отправляете запросы
если помогло нажмите: Спасибо!

Nosferatu112

LexaK, Я просто понять не могу почему с http всё работало а когда стало https всё накрылось

LexaK

Цитата: Nosferatu112 от 20 мая 2024, 17:01а когда стало https всё накрылось
другие методы/способы/условия соединения, найдите где нибудь рабочий пример соединения с  https
и по его примеру сделайте так-же.
если помогло нажмите: Спасибо!

antoneus

Соединение как создаете? Покажите код.

Nosferatu112

antoneus,

&НаСервере
Процедура НайтиФайлыНаСервереНовый()


ТекДата = ТекущаяДата();
//Дата = ТекДата - 86400;
Дата = "01.05.2024 00:00:00";
//Дата = Дата(Дата);
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЖурналЗвонков.Дата КАК Дата,
| ЖурналЗвонков.Файл КАК Файл
|ИЗ
| РегистрСведений.ЖурналЗвонков КАК ЖурналЗвонков
|ГДЕ
| ЖурналЗвонков.Дата >= &Дата
| И ЖурналЗвонков.Файл <> """"
| И ЖурналЗвонков.Отвечен = ИСТИНА
| И ЖурналЗвонков.ФайлОтправленДляТранскрибации = ЛОЖЬ";

Запрос.УстановитьПараметр("Дата",Дата);

РезультатЗапроса = Запрос.Выполнить();

Выб = РезультатЗапроса.Выбрать();

Сообщить(Выб.Количество());
Пока Выб.Следующий() Цикл

ПутьДляСохранения1 = КаталогВременныхФайлов();
ПутьДляСохранения = ПутьДляСохранения1 +Выб.Файл;
URL = СтрШаблон("http://10.0.128.30/calls/%1/%2", Формат(Выб.Дата, "ДФ=yyyy/MM/dd"), Выб.Файл);
//ПутьДляСохранения = "C:\Users\prog4\Desktop\ФайлыЗвонков"+"/"+Выб.Файл;
Заголовки = Новый Соответствие;
Заголовки.Вставить("API-Key", API_KEY);
Ответ = РаботаСИнтернетКлиентСервер.ЗапросHTTP(URL,,Заголовки,,,ПутьДляСохранения,,,,,,,);

Если Ответ.КодСостояния = 200 Тогда


URL = СтрШаблон(
"%1/upload/%2",
SERVER_URL,
SERVER_FOLDER
);

ДвоичныеДанные = Новый ДвоичныеДанные(ПутьДляСохранения);

Разделитель = СтрЗаменить(Новый УникальныйИдентификатор(), "-", "");
ИмяПараметра = "file";

Заголовки = Новый Соответствие;
Заголовки.Вставить("API-Key", API_KEY);
Заголовки.Вставить("Content-Type", "multipart/form-data; boundary=" + Разделитель);

ТелоЗапроса = Новый ПотокВПамяти();
ЗаписьДанных = Новый ЗаписьДанных(ТелоЗапроса, , , Символы.ВК + Символы.ПС, "");
ЗаписьДанных.ЗаписатьСтроку("--" + Разделитель);
ЗаписьДанных.ЗаписатьСтроку("Content-Disposition: form-data; name=" + ИмяПараметра + "; filename=" + Выб.Файл);
ЗаписьДанных.ЗаписатьСтроку("Content-Type: image/jpeg");
ЗаписьДанных.ЗаписатьСтроку("");
ЗаписьДанных.Записать(ДвоичныеДанные);
ЗаписьДанных.ЗаписатьСтроку("");
ЗаписьДанных.ЗаписатьСтроку("--" + Разделитель + "--");
ЗаписьДанных.Закрыть();

ДанныеТела = ТелоЗапроса.ЗакрытьИПолучитьДвоичныеДанные();

Ответ = РаботаСИнтернетКлиентСервер.ЗапросHTTP(
URL,
"Post",
Заголовки,
, , ,
Ложь,
,
SERVER_PORT,
, ,
ДанныеТела
);

//Запрос = Новый Запрос;
//Запрос.Текст =
// "ВЫБРАТЬ
// | ЖурналЗвонков.НомерЗвонка КАК НомерЗвонка,
// | ЖурналЗвонков.УникальныйНомер КАК УникальныйНомер,
// | ЖурналЗвонков.ВнешнийНомер КАК ВнешнийНомер,
// | ЖурналЗвонков.ВнутреннийНомер КАК ВнутреннийНомер,
// | ЖурналЗвонков.Дата КАК Дата,
// | ЖурналЗвонков.Направление КАК Направление,
// | ЖурналЗвонков.Длительность КАК Длительность,
// | ЖурналЗвонков.Ожидание КАК Ожидание,
// | ЖурналЗвонков.Файл КАК Файл,
// | ЖурналЗвонков.Очередь КАК Очередь,
// | ЖурналЗвонков.Отвечен КАК Отвечен,
// | ЖурналЗвонков.Пользователь КАК Пользователь,
// | ЖурналЗвонков.ФайлОтправленДляТранскрибации КАК ФайлОтправленДляТранскрибации,
// | ЖурналЗвонков.ТранскрибацияПолучена КАК ТранскрибацияПолучена
// |ИЗ
// | РегистрСведений.ЖурналЗвонков КАК ЖурналЗвонков
// |ГДЕ
// | ЖурналЗвонков.Файл = &Файл";
//
//Запрос.УстановитьПараметр("Файл", Выб.Файл);
//
//РезультатЗапросаРС = Запрос.Выполнить();
//
//ВыборкаРС = РезультатЗапросаРС.Выбрать();
//Пока ВыборкаРС.Следующий() Цикл
// Запись = РегистрыСведений.ЖурналЗвонков.СоздатьМенеджерЗаписи();
// Запись.НомерЗвонка = ВыборкаРС.НомерЗвонка;
// Запись.УникальныйНомер = ВыборкаРС.УникальныйНомер;
// Запись.Прочитать();
// Если Запись.Выбран() Тогда
// Запись.ФайлОтправленДляТранскрибации = Истина;
// Запись.Записать();
// КонецЕсли;
//КонецЦикла;
КонецЕсли;
УдалитьФайлы(ПутьДляСохранения);
КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура ФайлыНайти(Команда)
НайтиФайлыНаСервереНовый();
КонецПроцедуры

Nosferatu112

antoneus,
Вот на этой строке
РезультатСоединения = СоединениеССервером(Результат.СтруктураURL.URL_СервераБезПротокола, Результат.СтруктураURL.Протокол, Прокси, Таймаут, Порт, Логин, Пароль);РезультатСоединения = Успех
Далее

Соединение = РезультатСоединения.Соединение;И на этой строке ошибка
ИначеЕсли ВРЕГ(Метод) = "POST" Тогда
Ответ = Соединение.ОтправитьДляОбработки(Запрос);

antoneus

URL = СтрШаблон("http://10.0.128.30/calls/%1/%2", Формат(Выб.Дата, "ДФ=yyyy/MM/dd"), Выб.Файл);
тут-то, может, https надо?

Nosferatu112

antoneus, Не, это место откуда я качаю файл
Ответ = РаботаСИнтернетКлиентСервер.ЗапросHTTP(
                URL,
                "Post",
                Заголовки,
                , , ,
                Ложь,
                ,
                SERVER_PORT,
                , ,
                ДанныеТела
            );
А вот здесь я его передаю

Nosferatu112

Nosferatu112, То есть я сначала скачиваю файл с http а потом передаю на https

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск