Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 июн 2024, 02:21

Отсеивание незаполненных реквизитов

Автор tomsdog, 20 мая 2024, 16:03

0 Пользователей и 1 гость просматривают эту тему.

tomsdog

Всем здравствуйте!Возник следующий вопрос:Я делаю дипломный проект по тематике "школа",и в нем я создал журнал,в котором идет подсчет среднего балла,путем сложения всех оценок и их деление на 31(столько у меня реквизитов "День",т.е "День1,День2,День3 и т.д",что в корне неверно,т.к не все месяцы имеют такое количество дней,а потому мне нужно сделать так,чтобы деление происходило лишь на те реквизиты,которые уже имею в себе оценку,а остальные код не брал бы в расчет.Хотелось бы понять сам синтаксис этого рода действия

Вот как у меня выглядит этот самый журнал вместе с кодом:

Максим75

tomsdog, смотрите, можно посчитать количество дней, когда были оценки.
используйте хотя бы ЗначениеЗаполнено().

LexaK

tomsdog, вообще примерно такой код (как вариант)
Для каждого лкСтр Из ОценкиУчащихся Цикл
    КоличествоОценок = 0;
    СуммаОценок = 0;
    Для каждого лкКол Из ОценкиУчащихся.Колонки Цикл
        Оценка = лкСтр[лкКол.Имя];
        Если Оценка > 0 Тогда
            СуммаОценок = СуммаОценок + Оценка;
            КоличествоОценок = КоличествоОценок + 1;
        КонецЕсли;
    КонецЦикла;
    лкСтр.СреднийБалл = ?(КоличествоОценок = 0, 0, СуммаОценок / КоличествоОценок)
КонецЦикла; 
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск