Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 июн 2024, 01:41

Показать ТабЗнач в форме обработки.

Автор maxxi, 13 мая 2024, 10:29

0 Пользователей и 1 гость просматривают эту тему.

maxxi

На форме имеется тзРеквизит1 с типом "Данные Формы Коллекция".
Я скопировал данные из тзРеквизит1 в тзРеквизит3 таким образом:
тзРеквизит3 = РеквизитФормыВЗначение("Реквизит1");   
Для Каждого стр из Реквизит1 Цикл       
   ЗаполнитьЗначенияСвойств(тзРеквизит3.Добавить(), стр);       
КонецЦикла;

теперь не знаю как показать тзРеквизит3 в форме в свернутом виде юзеру.
Форма=Объект.ПолучитьФорму("Форма");
ТаблицаФормы = Форма.Элементы.Найти("тзРеквизит4");
ТаблицаФормы=тзРеквизит3;
пробовал так, не получилось.
Спасибо.

antoneus

Зачем такой огород-то городить? На клиенте пишем:

тРеквизит4.Очистить();
Для Каждого стр из Реквизит1 Цикл       
   ЗаполнитьЗначенияСвойств(тзРеквизит4.Добавить(), стр);       
КонецЦикла;

тзРеквизит4 - это же реквизит формы с типом ДанныеФормыКолекция, правильно?

maxxi

antoneus,

antoneus

Ну круто. Колонки добавить только, чтобы имена с тзРеквизит1 совпадали и заработает.

maxxi

antoneus,

&НаКлиенте
Процедура Сформировать(Команда)

СформироватьНаСервере();

тзРеквизит4.Очистить();

Для Каждого стр из тзРеквизит1 Цикл       

ЗаполнитьЗначенияСвойств(тзРеквизит4.Добавить(),стр);       

КонецЦикла;

КонецПроцедуры

Скажите пожалуйста, а как применить метод Свернуть().
Спасибо.


antoneus

А, ну тут нужно на сервер ходить

тзРеквизит3 = тзРеквизит1.Выгрузить();
тзРеквизит3.Свернуть(Колонки, Суммы);
тзРеквизит4.Загрузить(тзРеквизит3)

Ну, то есть без заполнения тзРеквизит4 сначала, да.

maxxi

antoneus,

На клиенте так и оставить?

тзРеквизит4.Очистить();

Для Каждого стр из Реквизит1 Цикл       

ЗаполнитьЗначенияСвойств(тзРеквизит4.Добавить(),стр);       

КонецЦикла;


НаСервере
тзРеквизит1.Сортировать("Клиент");

тзРеквизит3 = тзРеквизит4.Выгрузить();

тзРеквизит3.Свернуть("Клиент", "Валюта");

тзРеквизит4.Загрузить(тзРеквизит3)

antoneus

Нет, не надо даже тзРеквизит4 сперва заполнять, я предыдущий ответ отредактировал.

maxxi

antoneus,

тзРеквизит1.Сортировать("Клиент");
   
тзРеквизит3 = тзРеквизит1.Выгрузить();

тзРеквизит3.Свернуть("Клиент","Валюта");

тзРеквизит4.Загрузить(тзРеквизит3)

Почему то не хочет сворачиваться.

antoneus

А Валюта - это колонка с числами?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск