Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 мая 2024, 06:35

Как правильно составить код записи внутри события ПередЗаписью?

Автор gulnyr, 08 мая 2024, 14:00

0 Пользователей и 1 гость просматривают эту тему.

gulnyr

Код:
Процедура ПередЗаписью(Отказ)
СпрАвто = Справочники.Авто.СоздатьГруппу(); //Создаем новую группу справочника
СпрАвто.Наименование = ЭтотОбъект.Модель.Наименование; //Добавляем название
СпрАвто.Записать(); //Записываем новую группу
Родитель = СпрАвто.Ссылка; //Присваиваем группу для элемента
ЭтотОбъект.Записать(); //Записываем результат
КонецЕсли;
КонецПроцедуры

Как правильно составить код записи внутри события ПередЗаписью?

antoneus


gulnyr

antoneus, есть справочники Автомобили. При записи любого элемента создается группа (записываем) и этот же элемент попадает в эту группу (опять записываем)

antoneus

Ну не при каждой же записи надо группу создавать, а видимо, только нового элемента? Значит, лепим проверку:

Процедура ПередЗаписью(Отказ)     
    Если ЭтоНовый() Тогда
        СпрАвто = Справочники.Авто.СоздатьГруппу();    //Создаем новую группу справочника
        СпрАвто.Наименование = ЭтотОбъект.Модель.Наименование; //Добавляем название
        СпрАвто.Записать(); //Записываем новую группу
        Родитель = СпрАвто.Ссылка; //Присваиваем группу для элемента
        //ЭтотОбъект.Записать();    //Записываем результат - не нужно, сам запишется
    КонецЕсли;
КонецПроцедуры

antoneus

Конечно, оригинальная структура - количество групп = количеству элементов, ну ладно.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск