Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 июн 2024, 03:13

Помогите начинающемуся сдать проект

Автор Пушкина, 07 мая 2024, 21:37

0 Пользователей и 1 гость просматривают эту тему.

Пушкина

Сделан ввод документа ВозвратТовараОтПокупателя на основании документа РеализацияТовара.

Нужно сделать : Ввод возврата должен быть доступен только в том случае, если с даты документа реализации прошло не более 14 дней. И только если документ реализации проведён.
Если возврат от покупателя был введён на основании документа реализации, нужно дополнительно проверять при его записи. Соответствует ли покупатель в возврате покупателю в документе-основании? Не превышает ли в табличной части возврата количество товаров реализацию?
Какой код написать????

Пушкина

Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)      
      
      
      
      
   
КонецПроцедуры
 

LexaK

Пушкина, почти все вправильно, так и вставляйте свои нужные проверки по порядку,
это пример, подставьте свои имена реквизитов
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)     
//проверка основания
Если ТипЗнч(ДокументОснование) = Тип("ДокументСсылка.РеализацияТовара")
и ДокументОснование.Проведен = Истина Тогда
//основание заполенено, реализация проведена
Иначе
Отказ = Истина;
ВызватьИсключение; "Возврат можно создавать только на основании проведенного документа: Реализация товаров.";
КонецЕсли;

//проверка покупателя
Если ДокументОснование.Покупатель <> Покупатель Тогда
Отказ = Истина;
ВызватьИсключение; "Не совпадают Покупатели.";
КонецЕсли;
     
//проверка Даты возврата 
Если Не ЗначениеЗаполнено(Дата) Тогда
дата = ТекущаяДата();
КонецЕсли;
Если ДокументОснование.дата > дата Тогда
Отказ = Истина;
ВызватьИсключение; "Возврат оформлен раньше реализации.";
ИначеЕсли НачалоДня(ДокументОснование.дата) < НачалоДня(дата) - 15 * 24 * 3600 Тогда
Отказ = Истина;
ВызватьИсключение; "Срок возврата превышает 15 дней.";
КонецЕсли;

//здесь добавьте проверку товаров,
//с учотом возможности создания 
//нескольких возвратов по одной реализации
     
   
КонецПроцедуры
если помогло нажмите: Спасибо!

Пушкина

LexaK, сдала, спасибо огромное Вам!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск