Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 мая 2024, 05:36

Не работает процедура СообшентеПользователю()

Автор Anton14101410, 29 апр 2024, 17:02

0 Пользователей и 1 гость просматривают эту тему.

Anton14101410

В данном коде не привязывается текст к реквизиту формы:


&НаКлиенте
Функция ПроверкаЗаполнения()
   
   Сообщение = Новый ОписаниеОповещения("СообщитьОЗаписи",ЭтотОбъект);
   ПоказатьВопрос(Сообщение,"Нужно ли заполнить вид услуги?",
   РежимДиалогаВопрос.ДаНет,5,,"Вы не записали вид товара",
   КодВозвратаДиалога.нет);   
   
КонецФункции

  &НаКлиенте
Процедура СообщитьОЗаписи(Ответ,ДопИнфо) Экспорт
     
   Если Ответ = КодВозвратаДиалога.Да Тогда
   
      Сообщение = Новый СообщениеПользователю;
    Сообщение.Текст = "Нужно заполнить поле доп. услуга.";
    Сообщение.Поле = "Объект.Наименование";
    Сообщение.Сообщить();
      
   Иначе
   
          Сообщить("Заполнено автоматически!");

   
   КонецЕсли;
     
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
   ПроверкаЗаполнения();
КонецПроцедуры

Максим75

Anton14101410, может путь к реквизиту формы указан не правильно.
посмотрите именно как реквизит называется на форме. Не реквизит объекта, а именно реквизит формы.

Anton14101410

Максим75, если убрать Проверка заполнения(), все работает

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск